Jump to content

(XBOX)BROKEN MAILMAN

Xbox Member
  • Posts

    9
  • Joined

  • Last visited

Reputation

4
  1. I had a ticket open on a different matter and asked the representative if they had known anything about it and they directed me to the forums. I wish someone had insight if I did something wrong or if this is a bug. Considering I'm hearing horror stories that you need to spawn him a lot to "farm" him. I don't know where to put this down and at some point DE will stop refunding my beacons back. I guess a better question would be to ask does anyone know a place that works, tried and tested?
  2. Sorry for the late reply, I was not host in a experience party on said tile set. Threw down the beacon and saw the swirling glowing red animation and then nothing. Happened twice.
  3. Oh, I 100% agree with you, because now you are stuck until next week unless you go looking for help on a seemingly simple mission. I definitely understand your frustrations because I have them too at times. If there is anything I can do to help let me know.
  4. The answer is.....Yes Just having some fun with ya, there is no announcement yet and for some people this is probably good because they haven't completed all 30 yet. So time to get some grinding done on my alt account. I want those Umbra mods!
  5. So what you're saying is you did the weekly "Help Clem" mission then doing NW missions a challenge came up to "Help Clem" but you already did the mission. I'm fairly certain you can just team up with someone that hasn't done the mission and be pulled through it. Correct me if I am wrong someone. If this is true just ask someone in region to help pull you through one. To answer the question though, he is a weekly mission and if "solo" is the only way you play you will have to wait until next week.
  6. Hopefully there is not another place dedicated to this topic I did search to see if there was anyone having this issue on this forum and saw no postings. Twice now I have placed wolf beacons down on Hydron on Sedna and it has made the animation of the beacon working but the wolf never showed up. DE was nice enough to refund me one of the beacons back which is more than I could ask for but am I doing something wrong? In the past I used to make him show up on this node and planet and now twice in a span of a few weeks I have placed, seen the animation of the beacon working just to never have the big guy come into play. Are beacons not a 100% chance of spawn, I have assumed they are which could be easily a mistake on my part if this turns out to be true. If anyone can help me in this matter (maybe I am doing something in error, I am humbly speaking not the sharpest knife in the drawer) with clarification on this matter I would GREATLY appreciate it. As of right now I'm scared to place another beacon anywhere for the chance I may lose another one.
×
×
  • Create New...