Jump to content
General Bug Report Guidelines - Please Read ×

Chains of harrow Quest won't load


SkinnyNetherRegions
 Share

Recommended Posts

So I got to the third Chains of Harrow quest (name "Retrieve Rell's Relic) and I went to play it, but got stuck on the loading screen at only a little past half way. I tried a few more times, just to be sure, but it still didnt load. I then tried several times over the next few days, and it wouldn't load at all. I had then taken a short hiatus from the game, and when i came back i had the SAME exact problem. I looked all over but no one is seeming to have it. I don't know if its something to do with the game or my computer being derpy, but i cant experience the new quests because its making the Chains of Harrow not complete-able

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...