Jump to content
General Bug Report Guidelines - Please Read ×

Revenant Quest not triggering in POE


BurnTheThirdSon
 Share

Recommended Posts

I've met all the requirements for this quest but it won't trigger in the Plains of Eidolon.

I have the mask of the lost one equipped on my operator and I've headed out to POE at nighttime like you're supposed to but when I enter POE the quest doesn't trigger and no white markers appear on the map, no message on screen from Nakak either. I went to the spot by Gara Toht Lake where you're supposed to go for the quest in operator mode but nothing happens.

Not sure why the quest isn't starting, the game let me buy the mask from Nakak and equip it but it won't let me continue the quest from there.

Link to comment
Share on other sites

6 hours ago, BurnTheThirdSon said:

I've met all the requirements for this quest but it won't trigger in the Plains of Eidolon.

I have the mask of the lost one equipped on my operator and I've headed out to POE at nighttime like you're supposed to but when I enter POE the quest doesn't trigger and no white markers appear on the map, no message on screen from Nakak either. I went to the spot by Gara Toht Lake where you're supposed to go for the quest in operator mode but nothing happens.

Not sure why the quest isn't starting, the game let me buy the mask from Nakak and equip it but it won't let me continue the quest from there.

I'm having the same problem. I got up to observer in quills a few days ago, just got the mask today, but nakak didn't say her line after you buy it and I don't see any markers in POE. I also checked the forums to see if other people were having this issue and a few were, but if any solution was posted it wouldn't work for me.

Edited by RayTay
Link to comment
Share on other sites

5 hours ago, RayTay said:

I'm having the same problem. I got up to observer in quills a few days ago, just got the mask today, but nakak didn't say her line after you buy it and I don't see any markers in POE. I also checked the forums to see if other people were having this issue and a few were, but if any solution was posted it wouldn't work for me.

I couldn't find any problems like it online, everything I could find was usually after getting the first marker or not receiving the BP upon completion.

5 hours ago, Catacomb said:

Ugh same here, was so hyped to get revenant. My guess is their new change to the quest (adding it into the codex) broke it. The codex acts as if i don't meet the requirements yet even though my operator is wearing the revenant mask.

Me too, I had all the parts and mats farmed ready for the BP. The same thing happens with me with the codex to.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...