Jump to content
General Bug Report Guidelines - Please Read ×

Excalibur Umbra in Arbitration is legit broken.


Skilullama
 Share

Recommended Posts

I was testing out arbitration for the first time. I started off using normal weapons then decided I had enough energy for my 4th ability. I used it for a bit and hit 0 and tried to swap weapons, it kept on my sword and I ended up having to jump off the map to try and fix it. After that error, I started to press E and use the sword and it just shot out exalted blades. I wasn't even using the ability, and my energy didn't drop overtime. The only time it dropped was when I held left click or clicked a different ability. I tried to activate exalted blade to fix it and all it did was make it the actual effect of exalted blade. I disabled my 4th ability and it just kept its weird 0 energy exalted blade.

I have some pictures to try to show it down below.

69QmTka.jpg

jMQvJrO.jpg

4BdwOgN.jpg

JvCfYeb.jpg

Pu1w1CB.jpg

NVEzKK1.jpg

nFhduv1.jpg

kzEU32j.jpg

  

Edited by Skilullama
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...