Jump to content
General Bug Report Guidelines - Please Read ×

Riven Unveil Bug


naskalpt
 Share

Recommended Posts

So I have 2 Veiled Riven mods, a rifle one and a melee one.

On both mods the condition to unveil them is to "Complete an incursion alone without taking damage". I've seen a lot of people just saying to go rhino and you're good to go but since I don't have Rhino I'm using Valkyr from the get go and I just completed 3 incursions (while leaving Cetus after each one) without taking any damage (0% damage taken) and nothing happened.

The "Riven Mission" shows up in the bottom of my screen. I've tried doing one at a time. I've even tried playing Ivara and just going invisible and not taking any damage as well...

I really don't know what more I can do, anyone has any idea to why it isn't working? Is it a bug or am I just doing it wrong?

I would appreciate any help

Link to comment
Share on other sites

29 minutes ago, Robolaser said:

Not sure if you're having the same issue, but I had to select solo mode to complete that challenge. It didn't work in the other modes even though i was alone in the plains when i did the incursion.

I tried it solo everytime, so that might not be the problem

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...