Jump to content

Anyone else have Enveloping Cloud problems? (Wukong)


(XBOX)TokyoDreamer91
 Share

Recommended Posts

So I recently been using Wukong with his augment, enveloping cloud, and I do see a few errors here, unless I'm misunderstanding the augment.  For one, the augment says, "Allies within 4m of the cloud become invisible to enemies for 14 seconds".  In game, I have noticed that a timer comes up by an allies name (within range).  This timer usually varies based power duration, but generally around 35 seconds.  Sometimes the invisibility doesnt appear right away when ability is casted and allies are within range.  It also seems to be that they aren't consistently covered, they are SOMETIMES covered and sometimes not.  Maybe I just dont understand the augment but it just seems to me that something doesn't add up with this augment.  Anyone else have issues with this augment?

 

By the way, not sure where to post this so I apologize if I posted in the wrong area.

Edited by (XB1)SAOxSonicKirito
Link to comment
Share on other sites

2 minutes ago, (XB1)SAOxSonicKirito said:

By the way, not sure where to post this so I apologize if I posted in the wrong area.

You wanted Players helping Players.

As for the augment, people lose the buff when attacking. It's not even remotely worth using.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...