Jump to content
General Bug Report Guidelines - Please Read ×

Game really this buggy or am I just unlucky?


CatPresident
 Share

Recommended Posts

I want to start by saying I love this game, but it seems this game doesn't feel the same about me...

In the last 2 weeks I've encountered the following bugs:

- The War Within looped after completing it. Apparently a old and known issue.
- During a timed mission, the datamass fell thru the floor into the abyss after popping out of a terminal. None of us could reach it. Aborted.
- Another timed mission, mid defense, Lotus said "abort the mission and kill everything in sight". Four of us looked for 15 mins but no enemies spawned and the extraction didn't trigger.
- During an extermination sortie, the last mob spawned into a wall. The 3 of us tried for 20 mins and couldn't kill him. Aborted.
- During another sortie, Lephantis phase 2 didn't trigger (the floor didn't collapse). Lotus said the line she always says when phase 2 starts, but nothing. Again, had to abort. Next attempt, a person said the same happened to them.
- During a bounty, the drone was stuck in a hill and couldn't be hacked.
- During another bounty, while flying back to Cetus, my arch wing vanished and I started to run in the air, clipping thru the entire map. It was cool at first - I could kill stuff but they couldn't see me. But /unstuck didn't work, couldn't fall into a lake, and just clipped thru the Cetus door. Aborted.
- Eidolon mission refused to complete. I ran outside, back in, outside again, made sure the doors opened, closed. Flew around. Waited some more. Killed enemies. /unstuck, falling in a lake, nothing worked and after 20 mins I had to abort.

I'm new to this game, but this seems like quite a lot of bugs to encounter in my first 100 hours.  The War Within and Eidolon bugs in specific have made me pretty salty toward the game.

Is this game really this buggy or am I just really, REALLY unlucky?

Edited by CatPresident
Link to comment
Share on other sites

More bugs in the last week:

  • Octavia's quest: On the 3rd mandachord piece, the white light just stopped in the middle of a bridge. Spent 20 minutes running back and forth trying to dislodge it. It would follow me but would just stop in the same place every time.  Had to abort and retry.
  • During stage 3 of a Ghoul bounty: processor did not drop (or dropped thru the map maybe?), resulting in us failing the bounty.
  • Interception mission: last enemy spawned into a rock next to D.  It could shoot us but we couldn't kill it, and AOEs couldn't kill it.  We had 2 waves remaining. Had to abort.
  • Mobile defense: my team mate and I couldn't pick up the datamass. We also couldn't open chests or revive each other. Another person joined, was able to pick it up, and carried us thru the mission.
  • Eidolon bounty: Casting any ability, including trying to switch to my operator, just showed the message "Ability Already In Use". I could only shoot. Dying and respawning fixed the issue.
Edited by CatPresident
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...