Jump to content
General Bug Report Guidelines - Please Read ×

NOT a bug: Warframe freeze on sound level or mic mute/unmute change (& a fix)


Graavarg
 Share

Recommended Posts

)Since late spring/early summer I have had a recurrent problem, in that Warframe would freeze whenever I changed the sound level or muted/unmuted the mic while gaming (from headset, keyboard etc.). This is on Windows 10/64 and a top gaming rig, and using Logitech products and Logitech Gaming Software (currently v. 9.02.61).

I suspected some update (mainly Warframe or Logitech) but finally grew irritated enough to actually test this. Having Warframe "freeze" every time I changed the sound level or muted/unmuted the mic by flipping it up or down (which I do without thinking) just became too much.

First of all, the game doesn't actually freeze, it continues in "the background" (you can still hear the sounds) while the interface, input & screen is frozen. It was possible to get back into the mission by Ctrl+Esc:ing back into Windows, forcing Windows to acknowledge the change by activating another software (like starting Edge, Notepad or whatever and then re-selecting Warframe by clicking the icon from the taskbar). Occasionally it was possible to just click on the Warframe directly. A bit cumbersome, but doable. In any hot mission you would of course be dead when you got your game back into "live mode", but excepting Arbitrations even that was a small price to pay.

However, mashing some logic gears together I suddenly had this brilliant insight that the culprit could actually be something in between (the game and the Logitech software) that tries to transfer the screen focus from the game to Windows (without actually doing it). And so it is, the villain is actually the Windows notification system. Or at least it becomes the tool for whatever software it is that behaves badly.

I have tested turning notification off for the usual suspects (sound card driver etc. etc.), but so far the only way I have got rid of this nuisance is by turning ALL notifications off (using the main on/off setting, not the app specific settings). My suspicion is that this is an "internal system bug/feature" and thus not connected to any of the apps (where you can individually set notifications on/off).

If someone else has the same irritating problem, I just wanted to let you know that you can "fix" this by turning notifications off (just search for "Notifications" in the Windows 10 search bar and flip the "Get notifications from apps and other senders" to "Off").

 

Edited by Graavarg
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...