Jump to content
General Bug Report Guidelines - Please Read ×

Mask of Revenant Quest bug, (can't get blueprint)


Tranzitions
 Share

Recommended Posts

So the step I'm at is after building all of the revenants parts (chassis, systems and neuro), so what I did after getting the parts was going to cetus at night, and did everything and killed the revenant, however there was a host migration afterwards. Now when I got back to cetus, I didn't finish the quest, I didn't get the blueprint, I didn't get the girl to talk to me, etc. I went to my ship, check inbox and my foundary, no blueprint. I tried fixing this by going back to PoE at night, the quest doesn't even work anymore(there isn't a white circle to go to), I relogged and tried again, didn't work. I don't know what to do.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...