Jump to content
General Bug Report Guidelines - Please Read ×

Can't equip a veiled riven


yosamti
 Share

Recommended Posts

AS the title says, I have a pistol veiled riven mod and I can't equip it and I don't understand why, I tried all my secondary weapons and none of them had the riven appearing in the possible mods to instal. Can you help me understanding the problem. (Sry if my english is not very correct)

screens here:

https://ibb.co/m6JDOV
https://ibb.co/mUgpxq

Edited by yosamti
Link to comment
Share on other sites

I am currently also experiencing this same problem. Will be taking screenshots in a few minutes in case i need to upload them as well. I got a melee riven from yesterday's sorties and didn't have a problem..However today i got a pistol riven and like the person above me, I can see the veiled riven if i go to my mods section and it acts as it normally would with options such as transmute ect, but when i go to my arsenal to equip it to a pistol in order to unlock it, it doesn't show up for any of the guns. I have tried logging out and then back in and also completely reopening the client but neither has changed anything. I assume that it is a problem in relation to specifically pistol rivens considering the melee one yesterday was fine and the 2 of us on this post both have pistol rivens that the problem is occurring with, but that could also be a coincidence.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...