Jump to content
General Bug Report Guidelines - Please Read ×

[Critical] Host-client system getting more and more bugs


Onds
 Share

Recommended Posts

As in title, the system has become more buggy than ever. It has always had some issues, most of which could be worked around. With PoE more issues emerged. With Fortuna, it is getting ridiculous. Let me try to list some of the things going wrong with it:

 

- Starting a mision (any) from orbiter/cetus/fortuna and getting [?] votes on people entering. People have already chosen that specific mission - which means a yes vote - to join up in the first place. So why a [?] is possible in the first place is beyond me. This is a very old bug.

- Host status changing during votes on a new mission while not in existing free roam (aka not PoE, not orb vallis). This often leads to the squad disbanding, but the client still thinking a squad is active. This in turn leads to new missions having the client show it is searching for members, but in reality that will never happen and the system gets stuck. It is solved by choosing solo mode, starting a mission, cancelling the timer and then going back to public mode. This is a very old bug.

- Joining a public squad and getting wrong localized text on objectives. Example: I use my client in english, yet the other day i had french objective text for excavators upon joining a public mission. I thought this was a new bug, but i am told it is a bug since Plains of Eidolon.

- Objectives not showing the correct time/status or not showing at all. I am guessing this is a synchronization issue between host and clients. This is a very old bug.

- Various transitioning bugs between free roam and mission hub (vallis->fortuna, PoE->cetus). Example: Doing a bounty in vallis with 3 man squad. Finishing the last stage at the same time as a 4th member joins. Attempting to extract not working until a new mission was picked up outside. I am guessing this has to do with the 4th member having an active mission while the rest of the squad did not. I assume this is a new bug, or introduced with Plains of Eidolon.

- Host disconnections, jittery entity movements etcetera. Mostly this can be explained with the chosen host having a bad connection/routing to the clients. On occasion though it would seem the host should not have these issues though. Probably an optimization bug.

 

There are many more issues than the above, but those 6 are the ones a new player is most likely to encounter early in their game experience. And let us be honest DE, we all want both new and old players to have the best experience possible for obvious reasons.

So please, pour some time into properly fixing - or even completely reworking - the host/client system.

 

Sincerely,

 

- another among thousands of players loving the game who want to see it do even better

Link to comment
Share on other sites

17 hours ago, Onds said:

 

- Objectives not showing the correct time/status or not showing at all. I am guessing this is a synchronization issue between host and clients. This is a very old bug.

 

 

This. Throughout the entirety of an excavator segment of a tier 5 bounty mission, the objective just said "Activate the excavators"  I could not see the status of any of them.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...