Jump to content
General Bug Report Guidelines - Please Read ×

Overall low performance even on Low settings


PeterScarlet
 Share

Recommended Posts

I have been trying to play Fortuna since the update dropped and nothing is stable to the point where its almost unplayable. 

In Fortuna:

FPS drops to 30 while idle, when moving it falls to around 1-18.

In congested areas game stutters and has input lag along with screen tearing.

Outside Fortuna:

Extreme lag, 30 fps idle, 18-24 while moving (on low settings 59 fps while idle 28-38 while moving). In area with enemies lag and input delay becomes extreme. Bounty overlay still remains on screen. 

K-Drive has extreme lag and input delay.

Archwing moves extremely slow and the boost makes no difference. At times the Archwing wont fly in the direction I want it to go. It also drifts to the left or right while trying to go in any direction.

I also tried turning off directx 10 & 11 it made no difference and I tried on 2 difference PC and have the same results.

 

my rig:

Intel(R) core(TM) i7-7700HQ CPU @ 2.80GHz

GeForce GTX 1050 TI

Edited by PeterScarlet
Link to comment
Share on other sites

I get consistent 11 fps if playing on my normal low settings. When playing on windowed 800x600, lowest possible custom settings, I get 21fps and it's still barely playable.

There needs to be some serious optimisation on this map, because you can't fish at 800x600, doesn't matter what anyone tells you.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...