Jump to content
General Bug Report Guidelines - Please Read ×

Game consistently Freezing for one second every two to three seconds


AWWWWWWWWWWWWWWWWWW_HECK
 Share

Recommended Posts

As soon as the game starts, the game will intermittently stutter every couple of seconds.

video: https://i.imgur.com/OiVgiKa.gifv

this occurs in every part of the game ive tried so far. i tried verifying game cache, optimizing the cache, updating video drivers, changing display modes. Nothing helped.

I just reinstalled the game today after a couple months, so a fresh install is not the issue either. 

specs:

CPU - Intel i7 7700k

GPU - Gigabyte GTX 1070

MOBO - MSI Z270 Gaming

16 GB of RAM

OS: Windows 10

 

any help is appreciated.

 

Link to comment
Share on other sites

I would advise using windows 7 if you mostly play games.Your specs are very good so that may not be the issue.I would advise next steps:

-Check your connection(reset your modem and also see if you are set on server closest to you in game settings)

-Enable fps counter(check fps and ping)

-Check running processes on your computer(end some non system programs and see if anything changes)

-Set windows update to check and install updates at time you are not playing(you cant turn it off on Win10)

-Scan your pc for malware or viruses.

-Use some softwate like AVG Tune up utilities,CC cleaner or some other to clean junk files and bad registry files...

-Disable some effects in display settings one by one and see if it would change anything.You could really run everything on high with your specs,but just in case.People reported some wierd game lags when Antiscopic filtering is enabled in Fortuna.

Link to comment
Share on other sites

On ‎2018‎-‎11‎-‎16 at 9:48 PM, AWWWWWWWWWWWWWWWWWW_HECK said:

As soon as the game starts, the game will intermittently stutter every couple of seconds.

video: https://i.imgur.com/OiVgiKa.gifv

this occurs in every part of the game ive tried so far. i tried verifying game cache, optimizing the cache, updating video drivers, changing display modes. Nothing helped.

I just reinstalled the game today after a couple months, so a fresh install is not the issue either. 

specs:

CPU - Intel i7 7700k

GPU - Gigabyte GTX 1070

MOBO - MSI Z270 Gaming

16 GB of RAM

OS: Windows 10

 

any help is appreciated.

 

Facing same exact problem..... everytime I try to load a mission, going to fortuna, login loading and stuff like that or open a browse. it just freeze like I really wanna play the game too...…

I tried everything. even re-install windows 10 fresh and install the game and still nothing.....

 

Specs: 

CPU: AMD RYZEN 7 2700X

GPU: Asus Cerberus 1070ti advanced

Motherboard: Asus ROG Strix X470-I 

RAM: G.SKILL TRIDENT 16 GB 8x2 DDR4 3200

OS: Windows 10 Home.....

 

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...