Jump to content
General Bug Report Guidelines - Please Read ×

K-Drive


Fritz22
 Share

Recommended Posts

I've got the same problem, been this way since i finished the fortuna quest line. 

Been back into my arsenal and its not in there, not equipped and not in the items to be equipped either.

Searched my inventory and the launcher just can not be found. 

Still waiting for a fix.

Link to comment
Share on other sites

  • 2 weeks later...

I have the problem that the k-drive doesn't show in my arsenal anymore, although its still in my inventory, and when i use the launcher it still launches the k-drive i bought. 
Looking at the problems above I remember equipping mods to my k-drive and going then going to Plains of Eidolon to test if the k-drive works there aswell. After that it vanished from my arsenal, but i doubt it has something to do with that.🤨

Link to comment
Share on other sites

So i have found sort of a solution for this which worked for me. Instead of the k-drive slot in the arsenal i had a heavyweapon slot with my archwinggun in it. but it was locked because i needed a gravimag to unlock it. So I bought one and unlocked the gun and my k-drive slot in the arsenal was back. But I feel it's weird that you need to have a gravimag and unlock the unlocked archwinggun with it so the k-drive slot shows...😶

Link to comment
Share on other sites

I found a solution that is consistent as well. I have tested it for the past few weeks and it still works for me.

 

Go into your vehicles tab and the board isn't showing, but instead click mod arch-wing and don't do anything. Back out and the board should be shown.

 

It works for me every time, but only when I don't do anything to my arch-wings. Hope this helps.

Link to comment
Share on other sites

  • 2 weeks later...
On 2018-12-27 at 10:16 AM, Johnny_Halloween said:

I found a solution that is consistent as well. I have tested it for the past few weeks and it still works for me.

 

Go into your vehicles tab and the board isn't showing, but instead click mod arch-wing and don't do anything. Back out and the board should be shown.

 

It works for me every time, but only when I don't do anything to my arch-wings. Hope this helps.

@Johnny_Halloween Yes this worked for me as well. It's definitely the a temporary solution until the devs fix it 😉 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...