Jump to content
General Bug Report Guidelines - Please Read ×

The New Strange 2/3 Stuck Bug


JahWarrior7
 Share

Recommended Posts

Hey all,

I am stumped. I currently am on the The New Strange mission and I have synthesized all 3 elite arid lancers on Ares, but the progress stays on 2/3. I have tried restarting my game and doing it at different times but it wont let me progress (did the exact same thing each time). Visited Cemaris afterwards too and no dice. Can anyone help or suggedt something? I submitted a support ticket for this earlier today. Any assistance is appreciated. Thanks! 

Jahwarrior7 

Link to comment
Share on other sites

same here .. tried yesterday first time .. did 2 of them .. and another 5 (0 standing) and I waited until today .. scanned the third one and 3400+ standing and still 2 out of 3.

Can we have an answer from the staff or someone that can tell us more about it?

 

Link to comment
Share on other sites

  • 1 month later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...