Jump to content

Weird K-Drive bug sequence


Zgwortz
 Share

Recommended Posts

A day or two ago, I ran into a very weird K-Drive related bug sequence while I was streaming a new account doing a Speed Run through the game. I was doing a bounty mission where, at the start, we had to kill N enemies.   As I came out of the Fortuna exit into the Orb Vallis, it showed the number of enemies to kill, but oddly had a line under the map saying "Race through the Gates" which I didn't notice at the time.  I got on the K-Drive and made my way towards the Enrichment Labs.   At some point, the Enemies killed number changed to Gates completed - again I didn't notice at the time.  On the way, I ran into a Coildrive and was knocked off my K-Drive.  I got back on my K-Drive and reached the Enrichment Labs.

That's when I noticed something wrong.   I saw the race indicator as it was finishing it's count, and around the same time realized I couldn't get off the K-Drive.   The Race gates finished and that display went away, not replaced with the enemies killed indicator, although that bounty was still running as my teammates were killing things.

I tried a lot of things to get off the K-drive - ramming into walls at full speed, doing tricks which should have failed, fire, aim glide, quick melee, nothing worked.  (It also didn't give me any trick scores...)  Finally made my way to the center of a group of enemies and let them kill me.  That put me on the ground, finally.

Except while it showed me dead, I was standing, and could walk around at full speed.   Couldn't respawn myself, but someone else revived me (while I was still standing - and the Kill N Enemies mission completed while they were reviving me...).   When I was revived, I still couldn't shoot or melee and it showed me hovering in mid air - I realized it still thought I was on the K-Drive.   I mounted the K-Drive, then dismounted, and *that* finally got me back to normal.

Fortunately, it was all saved on Twitch (at least for the next 14 days) for your viewing pleasure:

Clip showing K-Drive bug  - This is just the 3 minutes showing the bug from entry to the Orb Vallis to the point where controls got back to normal.

Full stream the clip was made from - Clip started at 01:54:57
 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...