Jump to content

My Umbral mods arent stacking.


EnotsKao
 Share

Recommended Posts

Send pictures? What you mean by stacking? Buffs from each mods not effecting each other? Can't place them together in exalted blade. Please be more specific. Please read up on this topic before posting.

Also if you're having trouble use the PC Bug Section of the forums OR seeking players help, there a section dedicated to that.

Edited by Kadishia
Link to comment
Share on other sites

Sorry sorta new to this how do I add screen shots?  But anyway when I put the two mods on, the bar deosnt fill up saying they have stacked together and the stats do not increase. I have tried it on a melee weapon and it works fine. Should I ask this on players helping players?

 

 

Edited by EnotsKao
Link to comment
Share on other sites

OP is referring to the Set Bonus on Set Mods. Just had a look myself, and indeed the set bonus isn't being applied on the Exalted Blade.
This is also true for Wukong's exalted weapon, and Valkyr's claws she gains from Hysteria. Doesn't apply to Ivara since she has a Bow.

When both Umbral mods are equipped to a normal weapon, the set bonus is applied as it should be, the mods get a slight buff in their effects if both are present. This doesn't happen on Exalted weapons, for whatever reason.

Link to comment
Share on other sites

2 hours ago, Voluundr said:

OP is referring to the Set Bonus on Set Mods. Just had a look myself, and indeed the set bonus isn't being applied on the Exalted Blade.
This is also true for Wukong's exalted weapon, and Valkyr's claws she gains from Hysteria. Doesn't apply to Ivara since she has a Bow.

When both Umbral mods are equipped to a normal weapon, the set bonus is applied as it should be, the mods get a slight buff in their effects if both are present. This doesn't happen on Exalted weapons, for whatever reason.

wait why? is there a reason that DE talked about before? it's especially odd when the sacrificial mods have special polarity on the exalted blade..

Link to comment
Share on other sites

This is a display bug. 

 When you apply the umbral mods to exalted weapons the set bonus on the umbral mods does not light up, as it does on normal weapons. 

However this is purely a visual error on the set bonus tracker. You can test this by doing the following, simply remove one of the two umbral mods and watch the stat display. 

Remove sacrificial pressure with sacrificial Steel still installed and you will see your crit chance decrease even though sacrificial pressure doesn't affect crit directly (what happens is Sacrificial Steel is losing its set bonus) and vice versa. 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...