Jump to content
General Bug Report Guidelines - Please Read ×

motion controls stop working when going from docked to undocked


(NSW)EbinFlow
 Share

Recommended Posts

Hey EbinFlow,

The Pro Controller will remain active when switching to undocked mode and will continue to be the primary device for using motion controls until you pair the Joy-Con again. Can you give this a shot and let me know if you are still encountering the issue?

Thanks!

Link to comment
Share on other sites

I think I understand what you were saying, and I believe that works. Here is what I did (which worked):

  1. I'm playing undocked with joycons attached to the device, motion controls are working.
  2. I turn the game off either by pressing the power on the top/left, or by docking it and walking away.
  3. [does real-life, boring, non-warframe activities for a bit...]
  4. I wake the switch using the pro controller
  5. The game wakes up, loads, but no motion controls are active.
  6. Go to switch dashboard, clicked controllers, select Change Grip / Order, press R & L, and return to game.
  7. Wildly flail about and enjoy newly enable motion controls 

 

 

 

Link to comment
Share on other sites

If you have no motion aiming in handheld mode after playing docked, just detach and re-attach your Joycon while in handheld. The game just needs the "please connect a controler" message to get motion aiming work again.

Edit: you have to disconnect your Pro Controller first when you switch from Docked to Handheld. Otherwise even the reattaching Joycon fix won't work. 
So it's: 
You play in Docked Mode with your Pro Controller -> You take the Switch out of the dock -> You go to the home menu and disconnect your Pro Controller in the quick menu -> You go back to Warframe and quickly detach and reattach your right Joycon. 
The game will then ask you to connect a controller. You have motion aiming now again. 
 

Weird fix but okay. 

Edited by (NSW)Kekwyre
Link to comment
Share on other sites

I had the same issue when going from table-top to joycons, and despite syncing the joycons and reordering them to primary/only controllers.

Not ideal, but I seemed to find a way around this earlier today without needing to restart by physically disconnecting them from the console and then reconnecting them again. Strange occurrence but it worked that one time, I've not tried it otherwise.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...