Jump to content
General Bug Report Guidelines - Please Read ×

Second syndicate ranking


KookieDeMojito
 Share

Recommended Posts

Hello all,

I am currently levelling on Cephalon Suda's syndicate and tried to get the first level for Arbiters of Hexis (principled), to get whatever they have to offer. I had the 5000 rep point long ago.

However, I gave my sacrifice (500 nanospores, which is not that easy to get) but I am still neutral to them and no reward was offerd (and I checked : the NS really have disappeared from my inventory). I tried to quit and start the game again (hoping this would be a tiny bug) but still neutral and if I want to get the next level again, things have changed : I now have to sacrifice 2 neuronal sensors (which seems to match to the Authentic ranking, just like if actually were Principled).

Now that I think about it, I think I already sacrificed a Forma in the Larunda Relay to get to Initiation rank, but didn't get the chance to reach it...

 

Looks like a strong bug to me, but maybe I missed a huge thing. I also tried to find any other topic on this kind of issue, but didn't so please do not hesitate to redirect to an old topic if needed.

 

Thanks !

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...