Jump to content
General Bug Report Guidelines - Please Read ×

K-Drive launcher lost


Nathraen
 Share

Recommended Posts

My K-Drive launcher is gone. Used it normally and build a new K-Drive

with the first 4 parts. Still worked fine and could use the new K-Drive.

Then the launcher just disappeared. Even tried to replay the Vox Solaris

Quest but nothing. Am I just stupid and doing something wrong or is it a bug?

Edited by Nathraen
Link to comment
Share on other sites

You aren't alone, while I have not built a custom K-Drive yet, I too have lost the launcher for it.  I've seen others saying they have also randomly lost their K-Drive launchers though I've seen no post nor legitimate fix for the issue yet.

Lost mine a couple days after Fortuna launched and, like you, tried to replay Vox Solaris to no avail.  Given how few of these posts I've seen (Like maybe only one every 2 or 3 pages), I would assume whatever triggers it isn't all that common.

Link to comment
Share on other sites

Can't say for him, but for me, I had it in slot 2 right after my Archwing in slot one.

Had been using the K-Drive on and off with no issues, then switched to mainly Archwing to grind bounties as they move faster. Having always had my scanners on the first slot and only having changed it to fit in the K-Drive, I decided I would move the Archwing to 2, and the K-Drive to 3, and put the scanner back on 1.

That is when I noticed the launcher was straight up gone from the gear list completely, and the slot that is was in was also empty as though it had just been unassigned.

Link to comment
Share on other sites

vor 12 Minuten schrieb AthosTheGiant:

did you keep the launcher after 10 items in gear wheel? if so, there is a possibility the gear wheel got reset(bug), try rechecking gears in arsenal.

It is nowhere to be found, not even in my inventory.

Link to comment
Share on other sites

i have also lost the k-drive launcher that was used in the quest that has vanished from my inventory and was wanting to know if i was to build a new k-bored if that would get me a launcher

how dose one submit this kind of bug to DE

Edited by alldog
Link to comment
Share on other sites

Seen a couple of posts saying if you get a new board that it restored their launcher, but also seen a couple that have said they tried that and it didn't work.

Would be better off waiting for an official fix in this case. You could end up burning plat/standing on only a chance when you can't really get more standing until you get the board back proper.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...