Recommended Posts

10 hours ago, notNSANE said:

hey @[DE]Glen, not sure if you read it, but I'm sure you will find this article interesting, it's by the Serious Sam devs and they found a huge problems with Windows drawing APIs too: https://medium.com/@alen.ladavac/the-elusive-frame-timing-168f899aec92

It's very detailed, like your post. Hope you can exchange notes! 🙂

I was about to post this! It deals with the same core problem, and there's some fantastic insight here. I noticed a lot of parallels between Alen's post and this research.

You'd think in year 2018 we'd be past such problems as "The GPU doesn't actually know how long it took to render out that last frame".

Share this post


Link to post
Share on other sites
6 hours ago, taiiat said:

your Notebook has a low end GPU on the Processor, as well as a Dedicated one that is much higher performance.
assuming that the Model Number of your Notebook that you gave is accurate(and that your Notebook has the i7-2630QM option rather than the i5-2410M option).

the iGPU in the 2013 Macbook Air is about 2.5-2.7x as fast as the iGPU in your Notebook, while the Dedicated GPU in your Notebook is about 2.3-2.4x as fast as the iGPU in your Notebook. in real world scenarios your dedicated GPU should fare a bit better than on paper though, as since it is a real GPU it has much faster Memory than the System Memory that iGPU's rely on (and Memory speed is a big deal for GPU's).
even so though, it's possible that the HD5000 in the 2013 Macbook Air outperforms your 560m by a bit (and the HD3000 on your Processor by a lot).

my recommendations for optimizing your performance are the same as i mentioned already (make sure games are set to using the dedicated GPU in your Notebook, turn on Dynamic Resolution).

Its a i7-2670QM. The processor itself does contain an intel hd 3000 chipset, but it must be disabled by Asus or something. It doesnt show up in device manager or any hardware or other software/driver options. That was the first thing i looked for back when i bought it. Oh well.

On a side note, i turned on dynamic resolution and and it runs steady at 60fps. I havent left the orbiter yet though. Ill try it again later today and see what actual gameplay looks like.

  • Satisfied 1

Share this post


Link to post
Share on other sites
14 часов назад, [DE]Glen сказал:

We already stop rendering when the game is minimized. The simulation still runs but it's not drawing anything.

@[DE]Glen Oh, may be you misunderstood me a bit, my game in borderless mode (not with window's controls, this is important)
If I minimize game, it restore back when I switch to another window, so game are always shown up under other windows, whatever I do it will restore back and utilize about 20-40% CPU and some % GPU (don't know how much). To be clear I have i7-4820k with GTX 1050 ti, 1920x1200 71.928 Hz and grapical settings in game set to maximum (FPS capped at 72).

Share this post


Link to post
Share on other sites
On 2018-12-05 at 5:29 PM, [DE]Glen said:

I'm super excited to see this change go out today. If you're like me and are using Max Framerate I'd love to hear if you noticed an improvement with this!

With Max Framerate set to 144 it's now showing 144 perfectly and not 142!

However, and i realise this might be a niché situation, i run with triple 1080p monitors at 120hz (if i ran all 3 at 144 then my poor gtx1070 would run at turbo speeds at the desktop idling... not ideal), but because of this i normally have the Max Framerate set to 120 with Vsync off. More to the point, it still shows 118fps  😞

XEFcInf.jpg

Edited by Conargle
spelling

Share this post


Link to post
Share on other sites
13 hours ago, taiiat said:

on Windows Vista, 7, 8, and 10 - when you are seeing or capable of seeing the Windows Desktop without minimizing a game or any other rendered Application you are running - the entire screen(s) you are seeing is always VSynced.

on Vista & 7 technically you can disable this by turning off Aero and using a Basic Theme. on 8 and 10 the Desktop is.... just always VSynced. for all of these, this is referred to as Desktop Compositing(or Composition, same word just different tenses). 
technically on Windows 10 you can force Desktop Compositing off, but it's really hacky and has some regularity in causing stuff to just randomly crash.

now i feel cheated by my win 10 .. i disabled v sync in Nvidia control panel and in WF settings ... i even pushed all settings on nvidia control panel towards high performance for launcher.exe 

tho on borderless fullscreen i dont see any inch of win desktop ...below my screenshoot and i dont see anything 

RL2QdbF.png

Share this post


Link to post
Share on other sites
On 2018-12-05 at 12:29 PM, [DE]Glen said:

 

However, as we continued to squeeze out more and more performance I found myself inching closer to that 60 FPS cap I had set and that's when I found a whole new set of problems.

On my PC I play with a mouse and keyboard but on my laptop I play with a controller because I find it more comfortable when I have my feet up in my recliner. One of the things that's easier to appreciate when you're playing with a controller is the consistency of your framerate: if the frame-rate isn't smooth and steady it's harder to aim because your crosshairs jump unpredictably. Paradoxically I found the closer I got to 60 FPS the less consistent my aim became!

  • The consoles were fine (they use Auto Vertical Sync and Dynamic Resolution)


 

Hi Glen, let me say first this is all very complicated stuff for me to understand. However, I think the issue with the aiming you describe above matches my experience exactly on ps4 pro.

Here is the thing.

When I play solo mode (when I believe I'm supposed to have better framerates) my aiming is quite sluggish and unresponsive. As soon as ppl start joining my squad, my aiming starts getting smoother. The more squad mates and enemies in the mission the more responsive my aiming becomes.

This made no sense to me, and I had been breaking my head trying to figure out why. I've blamed this issue on the controller deadzones, my internet, the auto aim option in the game. However, none of the adjustments I did to those things seemed to change the fact that my performance on solo is worse than in a squad.

I came across this dev workshop yesterday, and after reading that paragraph about better fps making aiming worse I decided to turn off Boost Mode on my ps4 pro, which supposedly increases fps, and to my surprise aiming overall feels much better, especially in solo mode. Having ppl join my squad still makes my aiming more accurate though, boost mode or not.

So, is it possible you could look into that? It's a real shame since I think boost mode makes the game look better. 

I know you said consoles are fine (if you were referring to the gaming consoles on the bonus notes) but my experience is exactly as you describe in that paragragh.

 

Share this post


Link to post
Share on other sites

@[DE]Glen Thanks for this change, it's made it possible for me to play on an ultralight.  Where before the last update I was getting very choppy gameplay at 720p with auto v-sync when in a squad, it's now possible for me to play at 900p (1600x900, to be clear) with v-sync off and the frame limiter set to 30Hz with dynamic resolution set to Auto in both cases.  There's the odd macro-stutter especially at the start of a level but it's quite smooth once the level is well underway.  It's good enough to where I'm considering playing on PC instead of the Switch where I just got to MR5 - primarily for M&KB which makes the gunplay much for fun for me. 

For others with ultralights: The laptop is an HP Spectre X360 13, the 4K screen version with an i7-8550U which has the 620 UHD integrated graphics.  On first start, the game picked 720p with all of the graphics settings turned to Medium (model quality, shadows, etc) but all of the effects enabled (Depth of Field, Motion Blur, etc) except for Ambient Occlusion which is turned off.  I now have resolution at 1600x900, v-sync off, max refresh rate set to 30.0, and dynamic resolution set to Auto.  I also bumped Texture Memory to High from the game's recommended Medium.

This keeps me at 30fps a large amount of the time with some dips to 26 or so.  There are some stutters occasionally but they're the large, loading something, kind and not the more irritating constant micro-stutter.  I'm happy to play on this until my main PC is available again.

The performance and graphical quality of the PC and Switch versions are very impressive, I'm honestly surprised at what you have achieved here.

Edit: I posted more detail settings to the /r/lowendgaming subreddit.

Edited by v1ld_wf

Share this post


Link to post
Share on other sites

Oh yeah, definitely smoother. 

Seeing some icons missing and resolution of some warframes dropping (looks very pixelated and can see edges) when dynamic resolution is left on. 

Not sure if localized. Have kept it off for now. 

 

Share this post


Link to post
Share on other sites
7 hours ago, -Bv-Psykiik said:

tho on borderless fullscreen i dont see any inch of win desktop ...below my screenshoot and i dont see anything 

i covered that, i was pretty specific:

Quote

when you are seeing or capable of seeing the Windows Desktop without minimizing a game or any other rendered Application you are running - the entire screen(s) you are seeing is always VSynced.

Edited by taiiat

Share this post


Link to post
Share on other sites

Wow, I knew something was up when my framerate counter was reading a perfect 200 instead of 186fps or whatever it was. I noticed it immediately and switched down to 144 to check and sure enough it was perfect! (almost) It is pretty consistent but it is just slightly off for me, I'll still notice tearing creeping up the screen from time to time. Though, the only way to actually fix that completely is to enable v-sync (or invest in a g-sync monitor 😎)

But this is all I really need, excellent change Glen. Love seeing Warframe being optimized to such an extent years after it's release.

Share this post


Link to post
Share on other sites
On 2018-12-06 at 4:51 AM, LeoMutreta said:

I have a high end PC and am forced to use a "craptop" (loved the term btw) just like you.  Im my case is a Samsung Ultrabook with Intel IGP.

Never used dynamic res in it.  Gotta try it asap.

Btw, great post.  Loved the detailed explanation.

On that note, what settings have you or Glen put Dynamic Res on?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now