• 0
Sign in to follow this  
Evvy21

I can't damage kyta raknoid

Question

Hello, i was trying to farm some toroids and while i was fighting some scyto and kyta raknoid spawned and i pressed my 4 on mesa and the kyta raknoid didn't took any damage and no it was not on it's invulerable phase.I have tried using numerous times in all possible phases of that thing nothing i just press 4 and mesa just looks at it,also tried using excal's 4 nothing happend 0 dmg.I thought at first i'm doing something wrong but i tried going behind that thing above etc. also i tried on more then 1 of them.The scyto ones the die no problem they take dmg.When fortuna got released i killed some of them in the first couple of days everything was fine.I tried fighting some of them last week same result not dmg.I'm not sure if it's a bug,feature of i'm just doing something wrong

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0

Check out this other thread on it with a good bit of advice etc :) 

Edit: Sidenote: It's also immune to WF powers while overshields are active.

Edited by -AxHx-Vile

Share this post


Link to post
Share on other sites
  • 0

This may be them being immune to abilities, or it may be a bug.

Kytas do resist most powers as far as I'm aware though. I usually beat them by a liberal application of Strun Wraith.

Share this post


Link to post
Share on other sites
  • 0

Bring a magnetic modded weapon when you're farming toroids, it helps vs the Orbs with overshields aswell as making short work of some of the jackals.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this