Jump to content
General Bug Report Guidelines - Please Read ×

Hydroid's ability 1 and 4 "charge and cast" auto-cancels itself


(PSN)Akyx94
 Share

Recommended Posts

Hydroid is amazing at interception missions for its crowd control abilities, however, one fatal flaw that has really ruined my enjoyment of playing this frame is the following error message whenever I try to charge and cast his ability 1 or 4:

"Activate again or hold to charge" ... this error message has haunted me for whenever I play Hydroid. Usually I'm "wtf!" whenever that happens but the problem is that it happens a lot!

I'm using the "ability menu" due to the ps4 controller's lack of buttons. Whenever I charge Hydroid's ability 1 or 4 and then let go of the ability button to cast it (when the charging wheel is clearly full) it would frequently cancel my casting with the error message stated previously. When I cast it a second time, it works every time, however, it's really annoying when my face is tanking all the shots because of me trying to recast a charged ability due to the first failed attempt (about +6 seconds of me being invulnerable).

I've tried mapping "ability menu" to L1 and (what I'm currently using) touch pad in order to free up my thumb to allow me to move or circle around when charging the abilities to allow me to get shot less. Both has gotten me the error message consistently.

I've even tried mapping the abilities to my d-pad (bad because I have to stand completely still to cast) which has also given me the error message consistently.

 

In the beginning, I thought I noticed a pattern where if I was moving while charging an ability it would fail with the error message when cast. However, standing still would also give me the error message. Likewise, if I'm charging beyond the counter/charging wheel having clearly reached full, I would also get the error. Nothing has stopped the auto-cancel and error message from appearing. Then, I noticed whenever a lot of enemies appear in my AOE reticle of ability 1 or 4, the error message would pop up when casting. However, testing this alone in the simulacrum, I would sometimes also get the same error although less frequently.

 

I don't know if it's a lag issue but this problem really kills my mood in playing Hydroid (and it's quite literally killing Hydroid too in clutch moments...). Searching the internet, I'm apparently not the first one who has experienced this problem - this problem has been mentioned in 2007. However, clearly a fix has not been made yet 😞

 

TLDR: Hydroid's ability 1 or 4 gives the error message "Activate again or hold to charge" and auto-cancels itself on the ps4 controller 80-90% of the mission when charging. It's literally "killing the frame ingame" and my enjoyment of using this really cool frame

 

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...