Jump to content
General Bug Report Guidelines - Please Read ×

Tekelu Skin on Imperator Vandal bugged out.


Lakais
 Share

Recommended Posts

I don't have the standard Imperator in my inventory, but on the Vandal version, the Imperator Tekelu skin is bugged out. When loading into the arsenal's vehicle section, the skin at first appears normal, but quickly degrades into what you see in the screenshot bellow over one or two seconds. 

Warframe0047_zpssqytru0a.jpg~original

Link to comment
Share on other sites

1 hour ago, HalidarSilvercloud said:

All Tekelu skins have been bugged since the 15th of November.

Not so for me. Just checked and this bug appears only on the Imperator and Vectis. I have the Vandal and Prime versions, respectively. These skins had no issues on Tigris, Orthos, Ballistica and Galatine Primes and the Prisma Veritux. 

Link to comment
Share on other sites

6 hours ago, Lakais said:

Not so for me. Just checked and this bug appears only on the Imperator and Vectis. I have the Vandal and Prime versions, respectively. These skins had no issues on Tigris, Orthos, Ballistica and Galatine Primes and the Prisma Veritux. 

Ah I stand corrected. Personally I only own the Vectis skin so I couldn't check the others. Sorry for spreading wrong info.

Link to comment
Share on other sites

  • 1 month later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...