Jump to content
General Bug Report Guidelines - Please Read ×

The Glast Gambit: Not Receiving Nidus Blueprint


dude511
 Share

Recommended Posts

Hey all, So once I finished The Glast Gambit quest after picking for Neewa to choose where she wants to go on her own, I did not receive the Nidus blueprint. I have tried to replay the mission but I cant and I have also tried to replay the transmissions in the inbox to see if that would trigger anything and it did not. I've also seen posts about this from about a year ago so I do not know if the problem was temporarily fixed or was never fixed at all. If there is any way to help me it would be greatly appreciated!

Edited by dude511
Link to comment
Share on other sites

  • 1 month later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...