Jump to content
General Bug Report Guidelines - Please Read ×

Mastery Rank not loading


Siris_Cree
 Share

Recommended Posts

The second Fortuna patched just dropped I exited and signed back in. No problem. When I came back in I recieved a message saying I reached Mastrey Rank 18. I did not say that before the patch dropped but I was really close to it so I figure a change in something must have just bumped me over so I went to Orcus Relay to Practice. I passed! so I went to Qualify nothing happened I tried a couple times. Nothing. I exited to Orbiter and tried to Qaulify through the Menu. I noticed it load for a second then stops. I tried turning the computer fully on and off just in case it was just a glitch. I qualifed for 17 about a week or so ago with no problem so i figure it has something to do with the patch. 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...