Jump to content
General Bug Report Guidelines - Please Read ×

Mesa Prime Access hotfix not showing up


(PSN)JAGarzzz
 Share

Recommended Posts

The Mesa Prime access update isn't there. I tried checking for updates but it says that the installed version is the latest version. When I try to open the game, it just stays on connecting. I tried logging into the warframe companion app on my phone and it says "Login failed checl your credentials." I tried different Internet xonnections, including our wifi (both wireless and ethernet connected), our cable box, and several data hotspots. Also, for a few weeks now (before the update) using our wifi wouldn't allow logging in, instead woth the error "login failed check your info"

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...