Jump to content
General Bug Report Guidelines - Please Read ×

Mask of the Revenant Can't begin/continue


(NSW)Vorkender
 Share

Recommended Posts

I'm a transfered player from PC, i transfered when, in mask of the revenant, natak asked me to build a part of revenant. When i started playing in switch, the quest was nowhere to be found, after a few patches the quest showed up in the codex as if i hadn't completed the minimum requirements for the quest. From then on i tried rising again the quills rank, tried to talk to natak multiple times, with and without the mask of the lost one, and tried to do the first mission as if nothing happened, however, it didn't work. Any solutions to fix it?

Thanks for the help ^^ (i just realized i might have posted this in the wrong place, if so, im sorry.)

Edited by (NSW)Vorkender
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...