Jump to content
General Bug Report Guidelines - Please Read ×

Mars Junction not rewarding properly


(XBOX)DazzlingSpoon30
 Share

Recommended Posts

I and a friend (on pc) are experiencing the same problem. We started Warframe after the Fortuna update. We opened the junction from Earth to Mars.We received the inbox message from the Lotus telling us we have received archwing blueprints and we need to go to the foundry to build it. But we don't have the archwing tab in their foundries, nor the blueprint in question anywhere. We can't progress in this quest because of this bug.

 

Further details:

I tried re-running Mars Junction from Earth and upon completion again I got the proper rewards. Friend on PC can not confirm if that fixed it for him. I did the mission originally about 3 weeks ago and he did his 2 days ago originally

Edited by (XB1)DazzlingSpoon30
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...