Jump to content
[DE]Megan

Buried Debts: Hotfix 24.4.2

Recommended Posts

Won't let me rebind buttons at all no matter what I do. Change ,save and confirm . Still same . Melee comes out . Blocks but that's it  . Melee toggle button doesn't do anything . I can do everything but use melee to attack . 

Share this post


Link to post
Share on other sites

When switching from the primary weapon into melee mode and picking up for example a power cell it needs to switch to the secondary weapon. Going into aim glide causes the switch back to the primary weapon and drops the power cell.

Share this post


Link to post
Share on other sites
Posted (edited)

Hi I followed the tips and suggestions and I have the same problem as before with the Xbox one controller wired with usb. I know you’re working to fix this but it feels like a Anthem/Fallout 76 level mess. I hate this, it was my go to game of choice. I will check back later hopefully this is not the end.

Edited by LokiCoyote

Share this post


Link to post
Share on other sites
18 hours ago, [DE]Megan said:

 

Hildryn Changes & Fixes:

  • Hildryn's Main Blueprint has moved from Vox Solaris' Offering Rank of Shadow (Rank 5) to Agent (Rank 2).

WOW, that is a MASSIVE change in rank.  Now it's actually easier to get than Baruuk, which came first (unlike how Revenant was higher level bounties than Gara... though neither one of those required any actual standing).

I heard people whining and moaning every time I logged in since Hildryn came out, saying they hated Little Duck more than anything else in the game.  I guess they must have whined and moaned a lot at you, too.  This strikes me as really quite odd, since no one ever complained about the Ventkids which are the most mindnumbingly boring grind in the game... at least you get to do a boss fight and actually engage in combat of some sort for Vox Solaris...

I guess there just wasn't a warframe behind it.

Share this post


Link to post
Share on other sites
Posted (edited)

This hotfix fixed logging in via steam controller, thanks!

 

However, melee is still not working with my Steam Controller. I've tried switching back to the official controller config, and also resetting the xinput controller config to default, with no luck. I can swing once, then it stops working. If I switch back to my primary, I can swing again, but only once. Interestingly finishers work fine back to back as it doesn't seem to swap to melee for them.

edit: I may have figured out the cause, though I can't test it. In the "Game" section of the Steam Controller config, there is only Quick Melee available, not Melee Attack. I tried switching to legacy keys and rebinding it as E, my melee button on keyboard, but it didn't help.

Edited by freykin
Adding more info

Share this post


Link to post
Share on other sites

Give me back my manual blocking! I would also like to use the quick attack for polearms again. And finally, open world events are getting old, quit pushing me to play in a bad area that I still have to put up with bugs in.

  • Like 1
  • Upvote 2

Share this post


Link to post
Share on other sites

still can't melee attack after switching to melee weapon using my controller. Except if using fire button enabled. I can melee attack just fine with that setting, but i can't quick shoot now.. oh well.. still not as fluid as it supposed to be. But i like this melee change actually. So fluid if everything works.

Share this post


Link to post
Share on other sites
20 hours ago, [DE]Megan said:

Buried Debts: Hotfix 24.4.2

Melee Phase 1: 'Flow' Changes:

Tenno, thank you kindly for your feedback, videos, and reactions so far on last night's Melee changes! We've been live for less than 24 hour with Phase 1 and we're going to start experimenting a little bit with some feedback. Our first experiment has to do with players who are truly committed to 'The Sword Alone'. 

  • Manual blocking/parry has been added when players wield only a Melee weapon in a mission (i.e NO Secondary or Primary equipped). This is possible because in this specific state, the keybindings are free to allow this manual blocking. We do not plan on adding it to any other state yet. The default keybind for this is RMB/Right Mouse Button, as it was in the past. 

Controller Changes & Fixes:

  • Melee Channeling can no longer be rebound on Controller due to it completely breaking Melee 2.99997 changes. We apologize for the discomfort this may cause for those who have built their controllers comfortably around a different binding. You can't make an omelette without cracking some eggs!
  • Fixed a widespread issue where players using Controllers could no longer Aim after the Melee 2.99997 changes. This affected numerous mechanics like Aim Gliding, Melee Channeling, etc.
    • We’ll be continuing to monitor controller issues as they arise! If you’re still having issues, restoring your Controller bindings to ‘Default’ will help in the meantime. Please let us know of further issues!
  • Fixed an issue where attempting to reload your Primary/Secondary while in Melee mode would not transition you back to your gun. 

Plains of Eidolon Changes & Fixes:

  • Removed Hildryn's Shield-gate mechanic that was applying to Eidolon Lures, resulting in an invulnerability for 3 seconds after their Shields are destroyed before becoming vulnerable again.
  • Fixes towards Teralyst (and possibly Gantulyst/Hydrolyst) getting stuck in the Plains which caused constant teleporting all over the landscape.
  • Fixes towards Teralyst (and possibly Gantulyst/Hydrolyst) not using abilities.

Hildryn Changes & Fixes:

  • Hildryn's Main Blueprint has moved from Vox Solaris' Offering Rank of Shadow (Rank 5) to Agent (Rank 2).
  • Greatly reduced the camera angle when casting Hildryn’s Haven.
  • Fixed Hildryn’s Shield Pillage not removing Status Effects for Clients.
  • Fixed Hildryn being able to use ziplines (and other context actions) while in Aegis Storm.
  • Fixed script errors when casting Hildryn’s Balefire.

Changes:

  • Improvements towards the Operator curly hair hairlines to show less scalp.
  • Balanced the Jat Kittag spark FX for less visual noise.
  • The Rakta Dark Dagger’s innate upgrade on equip is now called Mind Haze.

Operation: Buried Debt Fixes:

  • Clarified and corrected the Buried Debts data-hashes section of the World State Window to read as ‘UNDISCOVERED’ when you haven't scanned any data-hashes yet, instead of ‘SCANNED’.
  • Updated the Diluted Thermia description to read:
    • A magma like liquid that is diluted with coolant during the extraction process. Thermia can be found fracturing the surface of the Orb Vallis during thermal flare-ups. Could this be the key to weakening the Exploiter Orb's defenses?
  • Diluted Thermia now displays as a special pickup in the UI (similar to Argon Crystal, etc).
  • Amalgam Mods can now be Chat linked and found in the Codex.
  • Fixed a crash when engaging with a Thermia Fracture.
  • Fixed Coolant Canisters disappearing if you picked them up too quickly.

HOTDROPPED FIXES:

  • Hotdropped a fixed early this morning that was preventing players from downloading Warframe from the website. If you experienced this issue please try again!
  • Fixed real money purchased weapons (Prime Access, etc) not coming potatoed (Orokin Catalyst). Missing potatoes have been rectified to affected accounts in either your Inventory or the respective potatoless weapon depending on if you potatoed after the purchase was made. 

Fixes:

  • Fixed inability to login when playing in Steam Big Picture mode.
  • Fixed cases of some enemies not attacking in Plains or Orb Vallis.
  • Fixed a crash that occurred when unzooming or switch weapons during Mining.
  • Fixed inability to Trade if it includes an Ayatan Star.
  • Fixed Exard Scaffold not resetting damage resistances on Sentients.
  • Fixed Harrow’s Penance recast not refreshing Duration.
  • Fixed Gara’s Splinter Storm self timer not being refreshed when affected by Mass Vitrify.
  • Fixed the Tarock Thrown Blade Skin not applying to the Spira Prime or Hikou Prime once thrown.
  • Fixed missing FX/texture for Rhino’s Iron Skin.
  • Fixed missing Elemental FX for the Glaive Prime.
  • Fixed Kitgun FX lingering perpetually if the Glaive is also equipped.
  • Fixed Warframe Ability videos turning white after unfocusing on the Ability.
    • We’re still seeing some playback issues with these that we’re investigating! 
  • Fixed missing functionality when clicking an active Resource Booster in the UI.
  • Fixed Foundry UI notifications displaying a filepath.
  • Fixed [PH] context actions in the Mastery Rank 27 test.
  • Fixed a script error when accessing the Dojo Room Option Panel.
     

im still crashing upon launch idk if anyone else has this problem but i havent been able to play since the update dropped

Share this post


Link to post
Share on other sites

Can you fix the Corpus AI in Archwing Sabotage missions?  Only noticed this in Galilea, Jupiter, but the Corpus are displaying some erratic behavior, such as bouncing off walls like a tennis ball, getting stuck behind debris, and rocketing down tunnels instead of stopping.

  • Haha 1

Share this post


Link to post
Share on other sites

Maxed Vazarin users cannot use Void Blast anymore (24.4), seems to be the only school that is affected.

Share this post


Link to post
Share on other sites

Deployment of drones to mine planets are not working as it should. If you start one and go to the next planet the UI does not show to deploy another one, It only shows up on that new planet if you zoom in on the planet that already has a drone and then going to the new planet to keep the UI elements.

Share this post


Link to post
Share on other sites
Posted (edited)

Please. Instead of leaving Teno behind, make it so when people extract early, others get a selection screen to join extraction or remain. Otherwise we get unwanted host migrations, and potentially lost loot, progress, rewards, time, etc..

Please. Add a toggle for 'legacy melee' or new 'auto melee,' make the toggle a control which can be bound to a key so we can switch between legacy and new-style on the fly, when we realize halfway through a mission that we need it temporarily.

Please. Let us use aim down sites without leaving melee mode in the new system, or make that a toggle.

Please have a look at how exactly weapon switching works. Gun equiped; F switches guns. Great. Melee equiped; F quickly switches to last used gun, so press twice to switch guns. Great. Scanner equiped; F switches back to gun, and switches to the gun that you were not last using. This is troublesome, and should simply switch back to your last used gun.

I know in your original notes it said F switches guns, always. It doesn't though, and it shouldn't. Sometimes, we used melee, then ran around, then we want to be sure we have the right gun equipped, without firing. F will bring up our currently equipped gun. This is how it currently works and it makes sense, and it means 'aim' doesn't need to switch back to our guns. It is fun and awesome aim gliding with melee... and with the new system, if you want to use your gun mid-melee-aim-glide, just start shooting...

There are lots of problems with auto-blocking. Combos that require manual blocks for one thing. Channeling toggle combined with auto-block means rapid accidental energy depletion. How about tap channel toggle for channeling attacks only, long press to toggle on channel blocking and attacking. Or, you could even just have a toggle in options to simply disable channel blocking entirely because I think most players don't want to use all their energy to block, ever...

Also, please have a look at hit detection for spin attacks. I was testing on containers. Half the time spin attacks simply don't register hits... Spin, should be 360 degrees...

Edited by Arc5in
Spin attacks

Share this post


Link to post
Share on other sites

Please Fix Hildryn's Aegis Storm Control bug.

At now, Aegis Storm's 'altitude down key' bind with 'Crouch (hold)' key except 'crouch (toggle)' key

So someone who haven't use 'Crouch (hold)' key ppl suffer when use Aegis Storm.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...