Jump to content
YazMatazO

Latest Update(22/05/2019) broke the resolution of my client

Recommended Posts

42 minutes ago, Yzjdriel said:

Are you running on integrated graphics?

Nope, gtx 1050

Share this post


Link to post
Share on other sites

I got the exact same problem, tried to verify and optimize the cache as well did not help at all. The game just appear zoomed in to the top left corner when I go full screen at 1920x1080 rez. Using an GTX 1070.

Share this post


Link to post
Share on other sites
Posted (edited)

Exact same thing for me seems to happen whenever I use the proper resolution for my screen. Going one down seems to fix it.

Edit: New update fixed it for me. Thanks ❤️

Edit 2: Seems alt-tab broke it?

Edited by Dapper_Demon
Update fixed it then I broke it

Share this post


Link to post
Share on other sites

Same issue, 4k monitor with gsync running a GTX 2080. Seems to be broke across the board regardless of monitor/GPU combo.

Share this post


Link to post
Share on other sites
Posted (edited)

The issue, at least for me, looks to be due to Warframe not looking at the actual resolution that is selected within the OS.

Instead, it is "creating" (and forcing) its own resolution based on the custom scaling that is set, in my case, I use 135% with my 2560x1440p monitor and so Warframe is trying to say that I'm on an 1890x1063 which is simply wrong (when in Borderless Windowed / Windowed).

 

Hopefully this change is reverted as it completely breaks borderless windows / windowed (since it now uses that "pseudo-resolution" which makes things blurred / too-zoomed in) AND Full Screen (since it pushes things off the screen).

Edited by Sean

Share this post


Link to post
Share on other sites
Posted (edited)

The game had always a problem with my 4k display at borderless window for me. All way maxing at 1080p because I use 200% dpi scaling. But there was always a way around this. 

Now tho, no matter what option or compatibility mode I try there is no way to get the game running correctly in 4k without setting my OS into "tiny mode" 

Edited by bubbabenali

Share this post


Link to post
Share on other sites

same here, using borderless fullscreen on a lower resolution for now

Share this post


Link to post
Share on other sites

I also have this problem.  I run 2560 and 175 scaling, and the game now locks me at 1463 for Borderless Fullscreen.  On just Fullscreen I have to use 100 scaling or the mouse is locked into the top left of the screen.  This is a problem that happened in the past so it should have never came back!

Share this post


Link to post
Share on other sites

I gave a temp fix for this already . Ill try to be more clear . First set your windows icons size to 100 % if its not . Then open up your steam folder and navigate to C:\Program Files (x86)\Steam\steamapps\common\Warframe and open up the exe file . Or the launcher if you don't know what that is . It will say warframex64 …..file type is application . Now right click it and open up properties and hit the compatibility tab at top . Then check the box that says Disable full screen optimizations . Done .

 

If you check the box but don't set icons to 100% , then you cant scroll mouse cursor to bottom 1/4 of screen in game . Do both and its back to your res fullscreen mode . Also , when you do all this , open settings on launcher and set it back to fullsccreen .

Share this post


Link to post
Share on other sites

I am having almost the same issue, but in my case, but in my case I see all of the screen, but the mouse is still confined to the upper left quarter of the screen.

Share this post


Link to post
Share on other sites

Yeah.

Same here.

Honestly it's amazing how this got through QA...

Or maybe they just don't care about gamers on 4k.

Share this post


Link to post
Share on other sites
1 minute ago, IronKnightz said:

Facing same problem here running on 1920x1080 monitor

Did you change your windows scaling settings?

Share this post


Link to post
Share on other sites
2 minutes ago, Allexio said:

Did you change your windows scaling settings?

Just tried it seems to be working for now Thank You 🙂

Share this post


Link to post
Share on other sites
Posted (edited)
17 minutes ago, Allexio said:

Yeah.

Same here.

Honestly it's amazing how this got through QA...

Or maybe they just don't care about gamers on 4k.

Yeah you would think somebody at DE was using a high res display and thus had screen scaling enabled

Edited by andtannor

Share this post


Link to post
Share on other sites

Same problem. I used to play on 1920x1080, but after the update everything is off. I had no problems before the update

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...