Jump to content

Recommended Posts

1 hour ago, [DE]Glen said:

Windows 7:

twfVLWx.png

Windows 10:

othNAvd.png

Oooohh, pictures make it a lot easier to understand. Thanks.

I'm one of those hands on guys where I physically have to see it or hold it to understand. Which is why coding is beyond me.

  • Like 1

Share this post


Link to post
Share on other sites

This kind of Dev commitment to communicating real and good information to the community is just one more reason I'm proud to be a Tenno. 

  • Like 3

Share this post


Link to post
Share on other sites

After the latest patch (25.0.2) I am happy to report that everything looks to be resolved.

Spoiler

fDd4nVf.png

 

Share this post


Link to post
Share on other sites

Always interesting to see the people complain about bad UI, and FPS drops.  Then thinking it was a problem with the game, and not WinBlows

Share this post


Link to post
Share on other sites

Thank you for the very informative post and all the effort and sweat spent on the issues by the staff!

It's informations like this that really lets us apreciate the amount of work and love you put in Warframe.

Share this post


Link to post
Share on other sites
Posted (edited)

@[DE]Glen

I appreciate the strides you've taken to get hi-rez gaming running smoothly. Unfortunately, I still seem to have a problem. The following are screenshots I took just moments ago (while 25.0.2 was live):

Full Screen Windowed:

Spoiler

lhgdF95.jpg

and Full Screen:

Spoiler

54zxxfA.jpg

Previous to 25.0, there was no noticeable difference on object edges between full screen and full screen windowed. It has enlarged my Discord overlay.

Here is a PCPartPicker list of my setup.

Please let me know if there is any more info that would be helpful.

Edited by Moinphyst
Changed URL, added notice to discord overlay

Share this post


Link to post
Share on other sites
Posted (edited)

I recently moved from a 4k monitor with 150% scaling "down" to a 1440p 144Hz monitor so this would have affected me. So thank you very much for the fix and the great detailed explanation. I always like reading the details behind these kinds of issues as it could help fix a bug I have in the future. 

Edited by Septario

Share this post


Link to post
Share on other sites

Thank you SO much for working so hard on this man!  

What a complicated issue!  😞

Such pains.  Awesome read / informative though!  

I hope anyone having reso / scaling issues takes the time to read this “entire” post!

Share this post


Link to post
Share on other sites

This is exactly why I continue to support Warframe. The bridge between the development team and the community is well done. I’m impressed. Not many free to play games do this. 

Keep up the good work DE. 

Share this post


Link to post
Share on other sites
Posted (edited)

Hello DE Glen,

I've been playing Warframe on PC with a 4K display laptop, much like the situation you described, though I do have a modestly capable graphics card. 'Cause I like making things easy on my eyes to see/read, I personally have my DPI setting at 350% (Windows 10)...

Pre-update: The launcher window (where you'd have to click "play" to launch the game) was always "too big to fit on my display," but that wasn't too much of an issue since I could move my mouse to the bottom or top end, and that respective end would "scroll into view."

Post update, and post "High DPI support hotfix": the launcher window is still "too big" to fit in my display, but now I can't "scroll" the top or bottom into view. This issue here is that I now can't access the settings gear button at the top right of the screen without first changing the DPI in Windows, and restarting the launcher. Realized later that this because of something entirely unrelated to WF; so you can disregard that bit, but the "being too big to fit" part is still something that would be nice to see changed.

Thank you for taking the time to write a post explaining the background of this issue. It's good to be able to read and understand why things happen the way they do.

Edited by CHEMistry_Inc
More information, and corrections

Share this post


Link to post
Share on other sites

Ok logged in and changed my settings as I understood in the post and it works great. I am still on 4k and 60fps but text just looks better now. Really happy with my setup now.

Share this post


Link to post
Share on other sites
Posted (edited)

Edit, post-25.0.2: turned out that after the update (I just didn't run WF as of writing the post, so it was outdated even before it was written, lol) they added a setting in Display options, that if set to "Native" causes the game to AFAIK completely disregard the settings I'm talking about below (hence they probably never mentioned them, as I have noticed & wondered why). This is the setting that I'm now using, since it renders at true resolution set & on entire screen.

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

 

Since the problem is caused by how windows is scaling stuff, maybe changing Windows' settings regarding the specific app's scaling would help?

A while ago Win10 saw an update that made some games have weird resolution on my 1920x1080 125% scaled system. They displayed the game on entire screen, as it should be, but the resolution of the image was measly 1536x864, which was clearly visible and affected the scaling of interface elements or even lead to some being beyond the screen, in some games. Changing resolution in game settings couldn't help any, as it was already at 1920x1080. This wasn't the case for Warframe until the update (25 or 25.0.1, I believe) that "broke stuff".

Since I have found the solution back then I just needed to apply it to Warframe now, and it worked - all back nicely to how it was. I don't promise you it will work in your case, since your system & hardware are likely different (looking at you, 4K displays).

For the record, before doing these steps my "Override high DPI scaling behaviour", shown below, was disabled. This

You can see & click in properties screen of the Warframe executable (or right clicking on the shortcut you use to run the game😞

Spoiler

168962d1513799365-change-compatibility-m

Then override the scaling so it's performed by the application:

Spoiler

168964d1513799365-change-compatibility-m

Images linked from TenForums.com but this linked tutorial isn't the one to follow here (ehh, I didn't find one for the settings I'm describing).

Since your problems with 4K displays sound a little bit different than mine, I guess it would do you good to check the other two settings also.

I suggest doing it all while keeping in mind (though you may not need it, but it still may help)...

Spoiler

(or better, noting in a simple text file, for each test run the points below +their results):

  1. the settings you have in game for resolution,
  2. any in-game "window scaling" (I'm NOT talking about internal/rendering "Resolution Scale", which was implemened in there for long while now), and
  3. the global Windows' DPI/window scaling settings (like the ones right here).
  4. (the shown above app specific scaling settings, obviously)

Or just simple change will make it all work and you won't have to bother with documenting anything for yourself. 😜

Since the general problem seems to rely on the same mechanics I decided to post this little tip, seeing how it's not really mentioned anywhere, and only the global resolution scaling setting is considered.

I don't know how the settings will look like, or apply, on Win7 machine etc., so it might be slightly different or even not working at all - won't know for sure until you check it.

I will also leave it to @[DE]Glen to say if he considers it a good, if any, workaround in the short term, and which settings are best to be set for the future - for after they change more how the game handles the window scaling and all that stuff this op dev post is about.

 

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

BTW I really love reading dem dev post stories on how the stuff happens and is done, the road to finding a solution, the bug under bug thing, the "oh, there was some nasty code left there and it did xxx and xxx, and XXX also", the "nobody dared to touch that, because doing so would be a world of hurt", the "we wanted to do it this or that way, but Windows had a different idea on how to handle it, a bit unlike how we suspected it". ❤️❤️❤️

Last time I read something of this kind (oh, and not finished) was the Batman Arkham Asylum (or the other one of those) being reverse engineered & HxD Cheat Engine debugged by some advanced Russian programmer (translated to a language I could comprehend, English). Mighty interesting stuff, I say. I should read those like that more oftennnn. 😃

Like, like, "software gore,😀 but with a happy ending". 🤪🤪

Edited by trw31
outdated or incorrect info

Share this post


Link to post
Share on other sites
On 2019-05-23 at 6:53 PM, [DE]Glen said:

 If you were running at 4K before and are confused by everything getting big just set it to Native and hopefully it’ll be just like it was before.

The display settings screen could be better --

Oh YES it could be better. First you should default to keeping the old setting, at least if people have non standard ui scaling. Second, for some reason that setting is disabled in fullscreen, but it maintains the previous setting if you change it while in windowed or borderless mode... but there is no way to know that other than random experimentation.

 

> Savvy players would ask why their borderless fullscreen wasn’t running at their native panel resolution (not noticing that their frame-rate had improved!)

Yeah I noticed... but what do I need 300 fps for? Do as I say not as you think I want. I play on pc, if I didn't want a settings screen I would get a playstation. Also if I'm going fullscreen I'm going fullscreen, how is that not a clear choice? My screen can do the scaling if I choose a lower resolution.

Share this post


Link to post
Share on other sites
Posted (edited)

Nice explanation. I still have sometimes a problem with screen freezes (background sounds and gameplay continues). I played the game always at 1920*1080 and on native. I have had only problems after the U25 shipped never before. 

Edited by Szilvia

Share this post


Link to post
Share on other sites

I am only playing the game since the start with full hd and until this update it was not anzy issue with it or mostly I solved them. I just tried now to do a public jupiter survival run but constantly needed to restart my game because in 4-5 min randomly just screen freezed and could not finish any tries. This issue only exists with this game and what you wrote is interesting and hopefully you will figure out what is the problem because it is just frustrating to have to restart my pc all the time because this happens. I have only 1 monitor not a recent one but in the range of 5-10 year lifetime. I checked also these preferences what you mentionned but all seems to work as intended but yet I have this screen freeze issues. Never before happend with me in this game. 

I guess I need to buy a new monitor but the rest should be okay for the game. Windows 10 Home 64-bit, Intel Core i5 4590 @ 3.30GHz Haswell 22nm Technology, 16,0GB Dual-Channel DDR3 @ 799MHz (10-10-10-30), ASRock H97 Performance (CPUSocket), BENQ E2220HD (1920x1080@60Hz) 3072MB ATI AMD Radeon R9 200 Series (Gigabyte). This is my build for a long time and before it was a similar but older build but with the same efficiency.

Share this post


Link to post
Share on other sites

Wonderful read, and very helpful.
I was able to get things running properly after the update back in May.
Monitor native: 3840x2160,  Warframe resolution: 2560x1440 (Borderless Fullscreen),  Windows scaling: 150%

This resulted in a crisp clean view, free of aliasing and good framerate.  Today however, I opened the game and everything was ugly.  I haven't changed any Windows settings, and cannot figure out how to get Warframe to display at these settings again.

If I choose the Borderless Fullscreen option, the game sets resolution to the monitor's native and disables changes.  While in this setting (which the game says is 3840x2160 Borderless Fullscreen), something is clearly doing some form of scaling, but everything has terrible jagged edges (anti-aliasing is on high).  I cannot tell what resolution its scaling from, but it must be really low.  Screenshots taken using Warframe's (non-configurable...) keybinding results in a beautiful image.. the screencaps look better than what I see in-game.  When taking a screenshot in both scaled and native modes, there is no discernible difference either.  Because of this, I'm fairly sure a screenshot is generated outside the display process (done at the proper resolution, no matter what the current display mode is).

In windowed mode, at any resolution, the game is scaled up, but has the same poor quality as borderless.  This image quality issue is fixed if I select the new Native option, just ya know, no scaling, so its a small window.

Everything looks great if I set the game to 2560x1440 Fullscreen.  Scaling and all.  This works for now, I just hate not being able to multitask without all the screen shenanigans from minimizing a fullscreen window.

 

I hope some of this is useful for the hard work being done.

Share this post


Link to post
Share on other sites
Posted (edited)

Not sure if my issue is related, but switching to Borderless Windowed mode fixed a freeze I was getting on the first phase of the Vox Solaris quest in the Orb Vallis.

I'm one of the players reporting constant freezes in Warframe. In my case, the issue was completely predictable and reproducible, as follows: Speak to Thursby, enter the lift, find the Corpus Caches, down the drone, aaand BOOM. Freeze. It wouldn't always freeze in exactly the same place, but it would always freeze at this point. Sometimes Eudico would get to say her lines, sometimes I would get to 2/30 reinforcements killed and sometimes I would get to 17/30.

Anyway... short story is that someone in one of the many threads where people are reporting freezes connected the issue to this post.

To be clear: I don't have a high DPI setup. I have a plain 1080p monitor and the game is running at 1920x1080. Windows settings confirm this, and the NVIDIA control panel is set to the default "aspect ratio" scaling mode.

We therefore never thought about switching from Fullscreen to Borderless Windowed mode. My husband read "number of invisible fixes to Fullscreen" and after 8+ hours of troubleshooting thought, what they hey. What's trying one more thing?

Switching to Borderless Windowed mode fixed it. I was able to play through the Spy Drone stage of the Vox Solaris quest without freezing. Unfortunately it also means that I completed that phase of the quest, so I can't immediately go back and test to see if it was a fluke. However, after replaying that same portion of the quest 20+ times, and freezing up every time except this last one, I'm pretty sure the issue was Fullscreen mode.

In short: I don't have a high DPI setup, but switching to Borderless Windowed worked for me.

Thanks DE for this post, and for talking about the nitty-gritty details (i.e. "number of invisible fixes to Fullscreen"). If you hadn't, we wouldn't have thought to try this. Yes, the underlying bug is still there, but at least I can play while you work on it.

In case it's relevant to help troubleshoot the problem, my issue ID is #1863088. All the logs and stuff are there. Please let me know if you need anything else.

For the long story, here's my thread:

 

Edited by JaceRae
Fixed spelling mistake

Share this post


Link to post
Share on other sites
Posted (edited)

Yes - Some update ago - All of the sudden I could not use borderless windowed anymore because it never saves my resolution or anti-aliasing settings.

I had to switch to Full screen only,

Edited by 5nak3Doctor

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...