Jump to content
General Bug Report Guidelines - Please Read ×
Echoes of Duviri: Share Bug Reports and Feedback Here! ×

I can't play the game like this let alone to start it even.


Recommended Posts

I cannot upload the damn picture for some reason but whenever I start the game or the screen is displaying only a portion of it. It is if as the game was zoomed in to only the corner of the screen and I cannot zoom out. I tried changing my base resolution of my display from either 4K to 720p as it was originally set to 1080p when the problem first occurred and I tried to login but since of the new update that must've done something I tired moving my mouse into the unseen and try to find the button to play the game and change the settings from there but I got to no avail. I don't want to do a reinstall but I feel like I have to. Oof Please Help and thanks.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...