Jump to content
General Bug Report Guidelines - Please Read ×
Echoes of Duviri: Share Bug Reports and Feedback Here! ×

Arbitration Pick-Up, Ability Cast and Weapon Use Broken


Recommended Posts

So this just happened:

Went into a defense arbitration (Hydron) with Oberon (with phoenix renewal) + Smeeta kavat. Used hallowed ground and renewal frequently to heal my squadmates, everything went good - then at round 7 or 8 my kitgub stopped working (enough ammo), then primary (rubico prime). Melee still worked until I grabbed my focus and at that point I could not pick up any items anymore and couldnt cast any abilities (including operator). At round 10 I wanted to leave, but my input didnt work and so I stayed to 20, hoping it would change. Suddenly my primary worked again (until I ran out of ammo). Then at round 20, same deal, but this time my squad left - hostmigration. When I was alone, I could cast abilities again but the target died almost instantly after the enemies spawned.

I got no resources from that arbitraion (because I couldnt pick them up), my squadmates however did get them.

I hope this is any help, maybe someone encountered this bug too?

Edited by astrokatze
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...