Jump to content
General Bug Report Guidelines - Please Read ×
Echoes of Duviri: Share Bug Reports and Feedback Here! ×

Diwata not working at all


Recommended Posts


I popped into a plague star squad with my Titania, ready to hunt down some hemocytes and pop that boil. So when the hemocyte popped into existence I went, presses E and tried to use my Diwata to attack it to strip armor with shattering impact:

Nothing happened.

I mashed the E button and while the sword showed, nothing I pressed caused any effect. No meleeing, nothing. Aiming did swap back to the gun however. Thereafter I popped into the simulacrum to try to test if it was the mods’ fault, and with a fully unmodded diwata nothing happened as I mashed E either. With or without energy conversion, the effect was still the same: no effect whatsoever while the dex pixia continued to function as normal. My diwata build was as follows:

fury, gladiator vice, shattering impact, primed reach, motus impact, berserker, true steel.

Although the removal of all mods had the same effect.

While my Titania used the following:

steel charge, aviator, Intensify, energy conversion, Narrow Minded, razorwing blitz, Primed Continuity and Fleeting expertise.

This began happening after update 25.2.0, the Wukong rework. Please fix ASAP, would greatly appreciate.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...