Jump to content
Jade Shadows: Share Bug Reports and Feedback Here! ×
Jade Shadows: Known Issues ×

Bug: Mod Application


Shotinthedark79
 Share

Recommended Posts

if you have matching mods, it won't let you apply it if you have one already applied. Example: I have two ranked Piercing Hit mods, one for my rifle and one for my Dethcube. When I tried to put one on each, it would say I had it on my rifle already (and yes I tried both mods). An unranked Piercing Hit would go on fine.

Link to comment
Share on other sites

It's actually worse than that.  You have no idea looking at the UI which of your mods are connected to which of your frames, weapons, or sentinels.  So if you'd like to use a mod that is in use somewhere else, you have to laboriously go back & unequip that mod from everything until you resolve the conflict.

 

Edit:  The same is true for fusions as well.  If you have a mod on your frame & try to fuse it with a similar mod, you may be unable to do so because it would take ANOTHER frame on which is equipped over that frames point maximum.  So if you want to upgrade a specific mod you may have to unequip it from all of your stuff just to make sure you don't have this problem.

Edited by JerichoFayne
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...