Jump to content

Archived

This topic is now archived and is closed to further replies.

Plockrock

Game forces party disconnect in Plains/Vallis

Recommended Posts

First off, it's baffling to me just how poorly both Plains of Eidolon and Vallis run for me. I've checked and double checked and I'm plenty above the requirements I've seen listed for this game. I don't know if those are minimum or recommended.

But what's been happening is that I try to load in on bounties with my friends, and it takes me almost ten times longer to load these locations than they do - despite otherwise normal performance in other sections of the game. And then once I'm loaded in I'm hit with a tremendous FPS drop that makes the game all but unplayable for about three to four minutes. And if I do anything, absolutely anything within that period of time, I'm disconnected from the party and prevented from rejoining because "an objective has been completed." These dc's have occurred for any number of prompts ranging from equipping my Archwing and attempting to boost, down to just whipping my fishing spear out. I could understand if I just had a really poor PC and it couldn't run the game, but I don't; from every source I can track down, it's telling me that in regards to this game I don't. And if that were the cause, why would it cause DISCONNECTS rather than just poor framerate? Can anybody help? I don't have any clue why this is happening and it's actively harming my ability to play this game - I failed the Vallis fault-sealing event precisely because of this performance issue.

Share this post


Link to post
Share on other sites
17 minutes ago, Plockrock said:

I could understand if I just had a really poor PC and it couldn't run the game, but I don't

Well, my first assumption would be that you are viewing old specs. You haven’t provided a source, and you haven’t provided your specs. DE updated them a while back and third party sites have not been changed to match. Always use the Zendesk Support site for this. The minimum specs are also not really for open world areas, they are for standard missions. No, this isn’t logical, but that is just how it is. If you can provide your specs people might be able to help.

  • Not having a 64 bit OS could cause some issues.
  • Yoru internet speed and ping could cause you to DC. Some missions I have joined lately have been a bit strange (not open world). You load in and cannot skip the video. Then you get stuck on ‘catchup’ with other players. I have had stutters/freezing when this happens (less than 5 seconds). I cannot comment on if this is happening in open worlds.

 

The other option is your hardware. Is any of it failing/faulty? Are your temperatures okay? Are all of your drivers updated? 

  • You can Verify the Download Cache from the launcher, this sometimes fixes stuff.

Share this post


Link to post
Share on other sites

What is your computer specs? Windows version? RAM amount? CPU? Graphics card / GPU?

I found that having 4 GB of RAM and integrated graphics will struggle and mostly cause freezing in Free roam missions. My AMD Ryzen 2400g integrated graphics with 16 GB is plenty enough for Warframe.

Windows have Virtual Memory that may slow down to near freezing. Reduce Virtual Memory to 8000 MB or less might reduce the slowdown problem, at a cost of games and/or web browsers possibly crashing from out of memory. This is found in System, System info, Advanced system settings, Advanced tab, Performance settings, Virtual Memory.

If the game crashes with too small amount of slow Virtual memory, bring it back up. Your computer needs more DDR3/DDR4 RAM upgrade to speed things up by reducing any use of slow virtual memory.

Share this post


Link to post
Share on other sites

×
×
  • Create New...