Jump to content

Kubrow Incubator Problem "Unknown error"

Recommended Posts

I'm a new player of this game. It's a good game but there's a bug that bother me so much.

It was the first time that I tried to breed Kubrow at the incubator and it doesn't work. It would not breed a Kubrow but shows "Unknown error" instead.

I'd tried to change game languages and even reinstalled the game. But the problem is still there.

And I checked other posts in the forum, it seemed that I'm not the only one.

Please let me know if there is a possibility to fix this. It would be such a disappointment to play this game without a pet permanently.

  • Upvote 7

Share this post

Link to post
Share on other sites

Same problem here. All ticked for the requirements. Press random imprint and after just get an Unknown error message.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...