Jump to content
General Bug Report Guidelines - Please Read ×
Echoes of Duviri: Share Bug Reports and Feedback Here! ×

Triggered tutorial text crawl on Exploiter Orb


Recommended Posts

I was about to start running the Exploiter Orb Assassination mission on my own, in a solo party, but as soon as I placed the thermia in the condenser to start the fight up, the red text crawl from the tutorial popped up, and left my screen black. I could still aim and shoot, but I couldn't see and was promptly killed by the orb. I then tried to abort back to Fortuna, but the esc menu was missing all of its buttons, barring the nightwave button. Because of the circumstances, i decided just to alt + f4 out of the game. I tried doing the Exploiter Orb again, and the problem didn't happen, so it must just happen every now and again.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...