Jump to content
General Bug Report Guidelines - Please Read ×
Echoes of Duviri: Share Bug Reports and Feedback Here! ×

Cetus Bounty Mission Incorrect Objective


Recommended Posts

Cetus Bounty Levels 5-15 Phase 2


While me and my squad were helping a new player friend gain standing in Ostron, we ran into some progress stopping bugs. The first objective we had to eliminate enemies within the given area like usual; however, the target circle was outside of the map borders. We were confused, but not it was a minor bug so we went to another camp to get the enemies we needed.

After that we were prompted to collected 3 Grineer Caches. However, as displayed in the photos below, the objective icon told us to go somewhere 700m below the surface and the objective circle on the map was not close to the icon and half of it was off the map. We tried everything to trigger it by scouring the bubble, but nothing worked so we were forced to return to cetus and abort mission.

(KeithMcUno Point of View)
Within objective on map but waypoint icon is almost 1000m away.

(KeithMcUno Point of View)
Where the Icon was located, but still unreachable.

(Ichibei Point of View)
Map of objective.

Prior to accepting the bounty we were collecting Iradite and messed around by fighting the Eidolon Teralyst.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...