Jump to content
FallenFlame

Sentient Amalgam Mod Drops Bugged (again)

Recommended Posts

I probably should've realized this was bugged after getting Vengeful Revenant, 3 Vulpine Masks, 2 Combustion Beams, a War Hilt, and a War Blade before seeing any of the secret lab mods drop. This is definitely still broken.

  • Upvote 2

Share this post


Link to post
Share on other sites

After spending aaages writing all this to "support", having them say "oh you must not know how RNG works", then trying again from the start, they tell me to post it here and consider their ticket resolved.... <insert string of expletives here>

Copy-pasta from the second support ticket:

  • This is a follow-up to your previous request #1911576 "Certain mods not spawning correctly, like Repair Kit on release"

    Hi,
    If I may, I will explain from the start.

    When the update for Jupiter was first released, along with it came the release of some new mods, and the first (to my knowledge) enemy that does not attack you, but can drop loot (the roombas, which can drop the Repair Kit mod).

    While some players were apparently able to see the mod drop correctly and collect it, some were not.
    Within the same mission, one player could potentially see and collect the mod, while another could not. I have a screenshot where the mod was marked and picked up by one player, and I (as the only other player in the mission) had picked up nothing according to Mission Progress, and was able to pick up nothing from that location (there was no actual mod object there), just their waypoint on the leftover pickup object saying "Repair Kit".

    First question: are you aware of and can you acknowledge this past issue? It was fixed, so I expect it was known to programming staff. Either that or I traded for one and subsequent drops worked normally, in which case it's still potentially a bug. I don't actually remember.

    Second question is getting to my concern: these mods apparently having similar problems dropping, also on Jupiter.. It's not as clear cut as the Repair Kit drop bug, but I don't think I'm mistaken.. I'd just like you to actually look into it please?

    The situation is that both I and the other player with me saw a mod getting sucked up towards us, and heard the pickup sound, but nothing popped up on the screen to identify what mod it was.
    Due to the rarity of these enemies and their rare mods dropping and the time required to find the necessary rooms/enemies, it was very difficult to try and prove as thoroughly as the Repair Kit bug, but I believe the problem is perhaps similar in nature. I tried to ask my mate to stand outside, so I could try to mark the dud pickup the way we did with Repair Kit, but it's just super time consuming and if it did happen again during our testing, I was unable to find the leftover object after an item pickup to mark it.

    I appreciate your providing links to information regarding the drop rates of items, however it's not relevant here. I'm not saying "I think there's a bug, my rng isn't excellent". I have over 7k hours in Warframe so I understand how drops work, and I'm not asking you to give us a mod (I understand that is outside of the scope of support you can offer). I'm just asking you to look into whether there might be an issue dropping/picking up rare mods dropped by the Sentient Amalgam enemies specifically. Potentially when the player/account has never seen or picked up that mod before specifically.

    Thank you for your thoughtful consideration. Please take your time.

  • Avatar
    outseekerToday at 12:34

    I absolutely just saw a mod on the minimap, walked over to it and it got vacuum'd to me, but no mod popup and no mod. I want to say that I hear the *click* sound like when you pick up a resource instead of the mod pickup sound, but I'm not 100% certain.

    Also I was mistaken that the Repair Kit spawns are working correctly. I have seen multiple cases of the mod just appearing when I've not killed the roomba who was supposed to have dropped it, and one occasion where I actually found a roomba seemingly locked up in place, not moving, near an apparently random Repair Kit mod.
    I certainly appreciate that they are dropping them at least, if a little too often and on their own when disposed of by game code perhaps? Like I found a Repair kit in a yet to be visited hallway so maybe they're rolling for drops even when disposed of by the game itself and not a tenno. Just thought I would mention it, still no hurry. As you were ^_^

  • Avatar
    [DE]JoeyToday at 20:13

    Hello outseeker,

    Thank you for bringing this to our attention,

    If that is the case, I would suggest that you post this to the appropriate section on the Warframe Bug Reporting subforums located at the link below.

    Warframe PC Bug Forums

    These forums are monitored daily by Warframe moderators, developers, and designers responsible for fixing specific issues.

Share this post


Link to post
Share on other sites

It just did it again. This time I can confirm without a doubt that the mod object does spawn, and can be seen both on the minimap and in the world. When I picked up the mod, I also picked up some Hexenon, which made a *click* sound and displayed "Hexenon" on the HUD, but there was no mod pickup popup, no mod pickup sound, and no mod received.

This time I killed just one amalgam sentient with Hydroid's Pilfering Swarm, and it dropped 2 mods. I can absolutely confirm this is a bug as described, as my mission progress currently shows only 1 mod picked up at all, which is absolutely 100% incorrect, given this one enemy just dropped 2 visible mods.

Many thanks for your attention.

Share this post


Link to post
Share on other sites

In addition to mods marked HEXENON that give Hexenon when picked up they also drop mods labeled "Module" which give nothing when picked up:

PUXT0ma.jpg

  • Like 1
  • Upvote 1

Share this post


Link to post
Share on other sites

I noticed earlier in Kuva Survival that when I picked up a Rare mod such as Toxic Flight, there was a noticeable delay. Made me think perhaps you added a debug flag of some sort to me, so I went back to testing this mod drop.. No delay when picking up the dud mod sadly, so I guess maybe not XD

Further info however.. This bug is happening quite frequently it seems. 2 runs back to back, I had the dud mod pickup issue in a Jupiter lab room. and that's without the mod drop chance booster I did have earlier.

I was able to try and mark the mod this time, by using the operator, and no matter what angle I tried to mark it from, it instead marked the resource drop (in this case an orokin cell). I assume they're spawning in the exact same position when dropped? Pretty frustrating I couldn't ID the specific mod.

When I moved too close, both the orokin cell and the mod were sucked up together. The orokin cell was picked up and displayed as being picked up, whereas the mod just disappeared after being sucked in, as previously described.

Share this post


Link to post
Share on other sites

OK looks like it might not be specific to Jupiter, nor mod rarity..

Just came across 2 random mods on the ground during a mission on Venus - Orb Valis. Picked em up and got nothing pop up to describe them.

About 60% sure they didn't actually provide any mod but not sure what I had already picked up.

Share this post


Link to post
Share on other sites

 

This bug is dating back to August.  I've been poking the labs every couple weeks since then and it continues to be broken.  Can we please get a fix?

Edited by Callback
  • Upvote 1

Share this post


Link to post
Share on other sites

same happening to me.I did over 100 secret room (Sentient Labs) runs and on the last weekend I even intensified the mod farm and got myself a Mod Dropchance Booster from Baro Ki'Teer. I used Ivara and sometimes I had a Nekros with me for extra chances but none of the Mods dropped. So I definitely should have multiple Mods with that "Additional Item Drop Chance" of 2%.

Proof of doing more than 100 runs (sometimes I forgot to pick up the scenes and I didn't notice it as proof at first so I didnt pick them up at all at one point):

Spoiler

OI4oqkU

 

Edited by -VG-Obit
don't know how to do the image link... still having trouble linking the picture, just can't figure it out

Share this post


Link to post
Share on other sites

same happening to me.I did over 100 secret room (Sentient Labs) runs and on the last weekend I even intensified the mod farm and got myself a Mod Dropchance Booster from Baro Ki'Teer. I used Ivara and sometimes I had a Nekros with me for extra chances but none of the Mods dropped. So I definitely should have multiple Mods with that "Additional Item Drop Chance" of 2%.

Proof of doing more than 100 runs (sometimes I forgot to pick up the scenes and I didn't notice it as proof at first so I didnt pick them up at all at one point)

Spoiler

OI4oqkU

 

Edited by -VG-Obit
sorry, I just can't figure out how to link an image properly

Share this post


Link to post
Share on other sites

200+ of them killed, no mods but 2 orokin cells.

 

Why are they treated as "other" why not just have them be a normal mod drop?

Also here could be an ok fix, they drop from lab rooms and from the ones Alad sends against you.  Maybe the ones alad sends have a lower drop chance than the lab ones but still.

Amalgam (Swarm) Satyr: Kavat's Grace (all those legs should help it land easier)

Amalgam (Phase) MOA: Gale Kick (look at those legs)

Amalgam (Arca) Kucumatz: Anti-Grav Array (it hovers)

Amalgam (Cinder) Machinist: Odomedic (nothing says healing like fire)

Amalgam (Arc) Heqet: Could have a chance to drop them all

Edited by yarl5000
extra idea

Share this post


Link to post
Share on other sites

Killed 200+ of them over a past few weeks.  No mods but have gotten 2 orokin cells.

 

Keep seeing the mod "item" drop but it seems to be hexanon most times.

Share this post


Link to post
Share on other sites

Hey Tenno! Like mentioned in the other thread there might be two issues at play here. The first one is that Hexagon and Orokin Cells have the wrong pickup model for Amalgam enemies (generic mod model), this issue will be fixed in the next Hotfix. We are still investigating if the Amalgam special mods stopped dropping again.

  • Satisfied 1
  • Applause 1
  • Upvote 1

Share this post


Link to post
Share on other sites
4 hours ago, [DE]Saske said:

Hey Tenno! Like mentioned in the other thread there might be two issues at play here. The first one is that Hexagon and Orokin Cells have the wrong pickup model for Amalgam enemies (generic mod model), this issue will be fixed in the next Hotfix. We are still investigating if the Amalgam special mods stopped dropping again.

The acknowledgement and updates are greatly appreciated, thank you.  

Share this post


Link to post
Share on other sites

As of Hotfix 25.82, the special Amalgam mods are still bugged. Just like my other post, the mod is dropping (marks as "Module"), but nothing is actually gained from it. Here's a recording done just a few moments ago:

 

  • Upvote 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...