Jump to content
  • 0
tape_drive_TS1140

Amp damage nerfed?

Question

I used to be able to 2 shot vombs at poe with my 223, but now it takes 5-6 shots to murder 1.
What the hell happened? Is this an official change?

  • Woah 1
  • Upvote 1

Share this post


Link to post
Share on other sites

15 answers to this question

Recommended Posts

  • 0

Since your on the forums you can just check the update notes, and if its not there then mostly likely its a bug and should be reported

Share this post


Link to post
Share on other sites
  • 0

There was something changed about how the Shwaak prism works. Somehow my phone is unable to quote the original source from here, so I'll copy-paste:

"Fixed certain Amps no longer applying multiple instances of damage to Eidolons. This resulted in the Shwaak Prism feeling like it lacked punchthrough, when in fact it was the Eidolon who was not registering hits."

I wasn't sure what this means after reading this, but apparently something bad...

Share this post


Link to post
Share on other sites
  • 0
1 minute ago, (PS4)Viveeeh said:

There was something changed about how the Shwaak prism works. Somehow my phone is unable to quote the original source from here, so I'll copy-paste:

"Fixed certain Amps no longer applying multiple instances of damage to Eidolons. This resulted in the Shwaak Prism feeling like it lacked punchthrough, when in fact it was the Eidolon who was not registering hits."

I wasn't sure what this means after reading this, but apparently something bad...

It simply means that you were only getting 1 instances of damage verse multiple hits since punch through was not registered 

Share this post


Link to post
Share on other sites
  • 0
15 minutes ago, Hyro1 said:

Since your on the forums you can just check the update notes, and if its not there then mostly likely its a bug and should be reported

Captain obvious over here.

19 minutes ago, tape_drive_TS1140 said:

Is this an official change?

There is nothing in the last patch notes. Bug fix in the one before and then I stop looking after mainline. Asking if someone has other information is what the forums is about. A bug report is the outcome unless someone else whats to share something.

Share this post


Link to post
Share on other sites
  • 0
6 minutes ago, Hyro1 said:

It simply means that you were only getting 1 instances of damage verse multiple hits since punch through was not registered 

Well then... The bug fix might be bugged 😃

Share this post


Link to post
Share on other sites
  • 0

Same thing here with my Schwaak 223. Currently farming for 237 or something similar because my 223 absolutely sucks right now. I thought I had my original Mote amp in my gear recently when I used it or the Vom was a level 50 or something but it’s the Amp. I need to do some testing this weekend.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Unbuffed shraksun numbers are the same as before the mainline update for me. Just went into PoE and unbuffed 2 shot a bunch of voms. It seems to work fine?

Edited by Lolacrayola

Share this post


Link to post
Share on other sites
  • 0
6 hours ago, tape_drive_TS1140 said:

I used to be able to 2 shot vombs at poe with my 223, but now it takes 5-6 shots to murder 1.
What the hell happened? Is this an official change?

What levels are the Voms?  Voms can spawn at different levels.  Higher level voms obviously have more HP. 

Share this post


Link to post
Share on other sites
  • 0

yeah am pretty sure the Schwaak is still bugged it works fine on teralyst but not on gantulyst and hydro like when i shoot them under the legs i always got one hit reduced dmg like 300 ~400 and no punch through whatsoever one hit n that's it 

Share this post


Link to post
Share on other sites
  • 0
6 hours ago, tape_drive_TS1140 said:

I used to be able to 2 shot vombs at poe with my 223, but now it takes 5-6 shots to murder 1.
What the hell happened? Is this an official change?

Prism or Scaffold?

Share this post


Link to post
Share on other sites
  • 0

I've been having the same issue with my 223 or 233 amp (can't remember which one I have). It feels like I'm using the ungilded mote amp with the voms taking 5 to 8 shoots each. Hopefully they change or fix whatever the problem is.

Share this post


Link to post
Share on other sites
  • 0
21 hours ago, (XB1)SYNANGEL666999 said:

I've been having the same issue with my 223 or 233 amp (can't remember which one I have). It feels like I'm using the ungilded mote amp with the voms taking 5 to 8 shoots each. Hopefully they change or fix whatever the problem is.

I was $&*^ing around with my operator on the plains doing a riven last night and my 223 felt so weak; first time I've used it in months. Definitely not right.

Share this post


Link to post
Share on other sites
  • 0

It's been like a month since that bug with Shwaak Prism damage (or Vomvalysts damage reduction) occured. There were many threads in the forums about it, but nothing was done by DE: neither anything in patch-notes nor stealth-fix. Yes, I'm aware about this:

В 06.09.2019 в 16:05, (PS4)Viveeeh сказал:

Fixed certain Amps no longer applying multiple instances of damage to Eidolons. This resulted in the Shwaak Prism feeling like it lacked punchthrough, when in fact it was the Eidolon who was not registering hits."

but it's irrelevant.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...