Jump to content
Agaczo

Vasca curative doesn't work on my Smeeta Kavat

Recommended Posts

Yup, same here. While my Smeeta Kavat appears normal in missions, it's still got the red glow on the orbiter.

Edited by NoraTheWeirdOne

Share this post


Link to post
Share on other sites

I used more than 5 curatives but my Smeeta still has red aura everywhere, not just in orbiter...

Share this post


Link to post
Share on other sites

Yep, not working on my Adarza. Have originally extracted an imprint out of it and tried curative twice afterwards.

Share this post


Link to post
Share on other sites

The Vasca Curative is still not working after the recent hot fix.

My Adarza Kavat is still pulsing red from the Vasca Infection despite having used the Vasca Curatives several times after the hot fix in an attempt to cure it.

Edited by Valkyrie1968

Share this post


Link to post
Share on other sites

I'll add another report of the cure not working.  The Vasca is an all-around annoying and unnecessary addition.  They're a plague on the plains during Eidolon hunts.

Share this post


Link to post
Share on other sites

This is still a problem, wondering when it will be fixed. Does the disease do anything to them? I've been dealing with my kavat dying more and I'm not sure if it is just bad luck or has anything to do with it.

Share this post


Link to post
Share on other sites

Same issue with my Smeeta. Appears normal during missions, but the glow reappears while in the landing craft.

Share this post


Link to post
Share on other sites

Still having this issue as of today. I take my infected smeeta out into a mission, use the curative from my gear wheel, it flashes green and the red aura goes away and then it comes back as soon as I finish the mission. Done this three times now.

Share this post


Link to post
Share on other sites

I have an Adarza, but she's going through the same. Infected once, cured, now I can't cure her again despite the curative showing a green aura like it worked, but she's red again when I return to by Orbiter.

Share this post


Link to post
Share on other sites

Same problem. First I used a genetic imprint (which I rushed), then noticed my kavat was still red. Bought 10 curatives from Master Teasonai and have used 2 of them while in the Orb Vallis, but he still maintains his red vampy aura both in missions and on ship.

Edited by mttank

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...