Jump to content
Jade Shadows: Share Bug Reports and Feedback Here! ×
Jade Shadows: Known Issues ×

Can't play missions on Kuva Fortress


Kienatic96
 Share

Recommended Posts

Since the update dropped early in the morning, I haven't been able to play missions on the Kuva fortress.
When I click on a node, the countdown will start. When it reaches zero, it zooms in and the screen goes black. But, instead of loading. The hud is still there (The invasions, quests, episode status, change loadout etc) and remains there. A loading screen also does not start, and nothing ever loads.
You can't press escape or anything to get out of it either. You have to use the hud and press on a quest or something else to drag you to another node, to get out of it.

Link to comment
Share on other sites

Same issue here.

The spy mission on Pago, Kuva Fortress doesn't load. I get a black screen indefinitely. I can chat to the squad, but can't enter the mission. I have tried many, many times. It's only on this mission that that this happens.

I have tried the black screen fixes on the forum, changed my display settings, tried using Direct X 10 and 11, verified my cache and reinstalled the game.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...