Jump to content

Empyrean: Ivara Prime 27.0.6.1


Recommended Posts

1 hour ago, mr_manu said:

My flux capacity is 479, when I add mod Hyperflux it says increase energy by 28% which should be 479+134 resulting in 613. The real result is 577 which is 20.5%.
Next example is shield, which is 1384, adding maxima with 35% should be 1384+484 resulting in 1868. The real result is 1734 which is 25.3%

That sounds to me like it's just working off base stas, like mods do in the rest of the game.  577-479=98 which is 28% of 350.  1734-1384=350 which is 35% of 1000.

Link to post
Share on other sites
1 hour ago, gelignite4 said:

Railjack Forge QoL changes when? Engineers can rarely tell if the forge is busy or not without having to go through the animation sequence of yanking it down and manually checking.

small circle at the base of forge, if its incomplete, the forge is busy.

Link to post
Share on other sites

imperator vandal and probable also normal version of imperator

reload is awful now, it is reloading maybe 6 bullets per sec...I jsut see how ticks are comming with +3 ammo 2 times in 1 seconds

its just useless to fight against more than single enemy because how this archgun depent on its high firerate and so fast recharge

no I was unable to kill single more armored enemy on veil proxima, on a bit harder enemy than common fighters

I went with my ammo to 0 in moment taking away more than half of health of enemy (most of time corrosing its armor to be able to deal any damage...) and before I got recharged to even 70 bullets in clip to be able to make decent burst....its healed to full and again....I was not seeing any damage dealt to this

 

this need to be fixed ASAP or just on of not many weapons already usable here...will be another one useless to use at all

  • Like 1
Link to post
Share on other sites
2 hours ago, [DE]Megan said:


Railjack Changes & Fixes:

  • The Railjack name text now has its own separate color slot in the ‘Primary Text Color’.

May I ask you WHAT FOR? You guys censored Railjack names appearing in missions, because edgy bois could trigger sensible snowflakes.
What a waste...

Link to post
Share on other sites
6 minutes ago, Ikserdok said:

imperator vandal and probable also normal version of imperator

reload is awful now, it is reloading maybe 6 bullets per sec...I jsut see how ticks are comming with +3 ammo 2 times in 1 seconds

its just useless to fight against more than single enemy because how this archgun depent on its high firerate and so fast recharge

no I was unable to kill single more armored enemy on veil proxima, on a bit harder enemy than common fighters

I went with my ammo to 0 in moment taking away more than half of health of enemy (most of time corrosing its armor to be able to deal any damage...) and before I got recharged to even 70 bullets in clip to be able to make decent burst....its healed to full and again....I was not seeing any damage dealt to this

 

this need to be fixed ASAP or just on of not many weapons already usable here...will be another one useless to use at all

this

  • Like 1
Link to post
Share on other sites

Just wanted to mention this to make sure it doesn't get forgotten. Gamepad on PC was doing archwing blink, shortly after it was removed without a note about it that I saw, I believe this was because you didn't like how it was working on consoles and just swept it off of all gamepads at the time. Today Xbox got Emyprean and the blink back, but it's still not working on PC gamepad just want to make sure that's out there. (Well on Steam Controller anyway, I haven't tried to bind something straight to LB yet, but I know when it was removed before a generic LB bind or the Steam Input bind for this weren't working anymore)

Edit: Ok so LB is actually doing it now on Xinput, but as far as Steam Input actions go Archwing Move Down is not triggering this, really hope for a fix

Edited by Drex83
Link to post
Share on other sites
2 hours ago, [DE]Megan said:

Empyrean: Ivara Prime 27.0.6.1

Railjack Changes & Fixes:

  • Fixed Crewships being spawned as Tenno Faction, which resulted in numerous issues such as not attacking you, Fighters attacking it instead, and Railjack Turrets not doing any damage to it. This also fixes a fatal crash related to this bug.

@[DE]Rebecca, I'm not trying to sting you guys with a thermal spike or anything, and I know weird stuff happens all the time... but that was the most unexpected bug ever to be fixed.

 

... Also, the most hilarious one.

Link to post
Share on other sites
21 minutes ago, Ham_Grenabe said:

As if Trade Chat didn't have enough going on.

You're gonna need to make a few more trade channels and start enforcing where to post your trades. 

Trade channel has sucked since its creation, and you can already filter it, nothing else needs to be added. Third-party trading website has proven a far superior experience to using the trade channel anyway

  • Like 1
Link to post
Share on other sites
14 minutes ago, Ikserdok said:

imperator vandal and probable also normal version of imperator

reload is awful now, it is reloading maybe 6 bullets per sec...I jsut see how ticks are comming with +3 ammo 2 times in 1 seconds

its just useless to fight against more than single enemy because how this archgun depent on its high firerate and so fast recharge

no I was unable to kill single more armored enemy on veil proxima, on a bit harder enemy than common fighters

I went with my ammo to 0 in moment taking away more than half of health of enemy (most of time corrosing its armor to be able to deal any damage...) and before I got recharged to even 70 bullets in clip to be able to make decent burst....its healed to full and again....I was not seeing any damage dealt to this

 

this need to be fixed ASAP or just on of not many weapons already usable here...will be another one useless to use at all

If this is something like a nerf to the archguns and not a bug, it's the worst thing I've seen, making the Imperator useless. 😕

  • Like 2
Link to post
Share on other sites

Still having an issue with controller.

For Railjack/Archwing specifically, the X/Square/Y button for context action is also "Move Down" and cannot be unbound. when you change the key binding, you now have two buttons that function as "Move Down" and it becomes impossible to enter railjacks and enemy vessels without a keyboard.

Also Vector Maneuvering doesnt work at all on controller. Holding and tapping the boost button do the same thing.

Edited by TheFatDrake
Link to post
Share on other sites
Guest
This topic is now closed to further replies.
×
×
  • Create New...