Jump to content
Jade Shadows: Share Bug Reports and Feedback Here! ×
  • 0

Melee attacks switching my weapons


blazer572
 Share

Question

So I changed one of my setting in my options so if I have my melee weapon actually equipped, I can use my mouse 1 to attack. Something I noticed though is if I have my primary ranged weapon equipped, and I press E for a quick melee attack and attack a few times, it will un-equip my ranged weapon and switches to melee equipped if that makes sense. Has this happen to anyone else? Is there a way to fix this other then changing that one setting back? Its just a pain in the ass killing 2 or 3 enemies close to ya and then try to kill one a distance away and end up meleeing instead of shooting.

 

THanks

Link to comment
Share on other sites

4 answers to this question

Recommended Posts

  • 0
6 minutes ago, blazer572 said:

and I press E for a quick melee attack and attack a few times, it will un-equip my ranged weapon and switches to melee equipped if that makes sense.

That’s what it is meant to do. Quick melee brings out the melee weapon, aiming swaps back to ranged. 

Link to comment
Share on other sites

  • 0
14 minutes ago, krc473 said:

That’s what it is meant to do. Quick melee brings out the melee weapon, aiming swaps back to ranged. 

Yes but it doesnt. All it does is block. I have to end up pressing F twice to go back to my primary. 

Link to comment
Share on other sites

  • 0
6 minutes ago, blazer572 said:

Yes but it doesnt. All it does is block. I have to end up pressing F twice to go back to my primary. 

It sounds like you need to check your controls. I cannot get the same result as you. No matter how many times I pushed E, aiming still got the gun out again. I too am using the M1 to attack with melee.

  • I have to hold F to lock my melee out.
Link to comment
Share on other sites

  • 0
14 minutes ago, krc473 said:

It sounds like you need to check your controls. I cannot get the same result as you. No matter how many times I pushed E, aiming still got the gun out again. I too am using the M1 to attack with melee.

  • I have to hold F to lock my melee out.

Well im at work so later in the day when I get home ill try making a video and upload it to youtube. If I turn that setting off, it works as it should. But thanks for the response.

Edited by blazer572
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...