Jump to content
Jade Shadows: Share Bug Reports and Feedback Here! ×
Jade Shadows: Known Issues ×

Railjack mission unable to complete, forced to quit


(PSN)Leeme_
 Share

Recommended Posts

(PS4) Just played a railjack mission, saturn poxima. All went smoothly, received my first Quellor BP. Then we couldn't find the last 2 crewships to complete the mission, so a player eventually decided to leave, them being the host. The remaining 3 of us were able to finally locate the last 2 crewships, they were glitched inside of the asteroid hangar, and after 10 minutes of finding away to get past the barrier we could not shoot though, we were eventually able to destroy them. However, the mission could still not be completed, because there was a 'Disable asteroid hangar' went inside there to figure out what we were missing, there were no pings or mission objectives shown on the map / minimap and the yellow or red indicators were nowhere to be seen. Tried running around it and inside of it anyway, but everything I tried didnt seem to work. I got too frustrated and decided to leave, cause nothing was working, and I didnt receive any of the rewards after aborting. I would like those resources ideally, but not crucial, but I am really bummed out that i didnt get the Quellor BP, it didnt appear in my foundry etc either

Also long time running bug I know im not the only one but my regular weapons keep coming out with me into archwing when I leave the railjack, that one's no biggie its just a thing that happens hahha 

I'll upload the last 15 minute clip of what happened in case that helps: https://youtu.be/efsZzSa-5hE 

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...