Jump to content
Jade Shadows: Share Bug Reports and Feedback Here! ×
Jade Shadows: Known Issues ×

Friend's having some performance issues


PeckaPopycorn
 Share

Recommended Posts

So, my friend is having performance issues on the first tutorial mission, not allowing him to post to the forums for help. Basically he's suffering from mass frame rate dips and stuttering, as well as constant crashing. He's tried messing with the settings to little to no success. His specs are:

processor: Intel Core i3-7350K CPU @ 4.20GHz
Ram: 8,00 gb
video card: NVidia GeForce GT 71
System: Windows 7 (64 bit)
 

Link to comment
Share on other sites

15 hours ago, PeckaPopycorn said:

processor: Intel Core i3-7350K CPU @ 4.20GHz
video card: NVidia GeForce GT 71

NVidia GT 71? The closest is NVidia GT 710 which is extremely slow, slower then the CPU integrated graphics of i3-7350K. Get rid of NVidia GT 710 from this computer and just use integrated graphics.

https://gpu.userbenchmark.com/Compare/Nvidia-GeForce-GT-710-vs-Intel-HD-630-Desktop-Kaby-Lake/m77649vsm178724
https://ark.intel.com/content/www/us/en/ark/products/97527/intel-core-i3-7350k-processor-4m-cache-4-20-ghz.html

 

Edit: To add, just having the monitor plugged into integrated graphics is not enough, the system might default to "High performance GPU" which is NVidia, and GT 710 is slower, very slow. Switch to Power save GPU or just get rid of this old graphics card.

Edited by sam686
  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...