Jump to content
Jade Shadows: Share Bug Reports and Feedback Here! ×
Jade Shadows: Known Issues ×

Steam Controller/Input has issues with railjack, here's some of what we need to fix it


Drex83
 Share

Recommended Posts

I wanted to open by saying I'm super glad that DE chose to support Steam Controllers/Input. I know it's been a bit of a headache for you guys to keep up on but it's great for those of us using it when it works! I wanted to make this post to try to narrow in on the key issues missing in the Railjack update on here to get the controller working again properly with this update. Also I'm longwinded as hell so I apologize in advance.

I think many games may still not natively support it (even though it can be generically used but not as well) but I think it's worth noting that while the Steam Controller got discontinued, the v2 patent's been filed months ago, I don't know if they'll use it but I do know, that they had a fire sale and sold out all units world wide in December. So, there's probably more Steam pads out in the wild than ever before, and while many don't look, the other major pads are all supported by it, which is why I feel it's important to update this when DE gets a chance. Steam's software for pads is quite useful for doing not just different binds, but more importantly, allows non-Xbox pads to work more like they should, such as allowing PS4 pads to use their touch pad, or using the gyro on switch/playstation controls which is paramount in making aiming waaaaay better if setup correctly. Not to mention the ability to alt tab out of games, and a desktop profile for browsing and stuff without dropping the pad. Before I really started I just wanted to mention these notes for why I feel this input API is good and should continue to be supported, since it really can support every PC player not just Steam Controller users.

Anyway, moving on here's the biggest issues thus far. First off, as I'm sure you're aware, every pad setup handled in game, has what I believe in your EE.logs when they rotate, refer to as, "input filters." (Or at least I think that's what those are, I think I saw one for transference before in the logs but that one is accessible in the game menus, maybe some are hidden? dunno) These filters are used so there can be a separate config for menus, railjack, frame fighter, etc. I'm sure DE knows what I'm talking about but to steer my point here's an image, look at the tabs up top in this image:

https://imgur.com/a/1M14ujd

Ok so onto Problem #1!

The tl;dr of Problem #1: There's no Railjack action set, this needs corrected, some actions need copied to this new set, and missing actions need implemented

My commentary on Problem #1:

So here's the thing, Steam's Input, uses it's own pad binding software. Games, like Warframe, which support binding directly to in game actions instead of regular binds, can automatically switch input filters (or as Steam calls them "action sets") on it's own without the game handling it. The problem is, no action set has been added for Steam Input for Railjack yet (or Shawzin, actually, but that's not really important to gameplay but would be a nice bonus!)

As you can see here in the second image, we're completely missing the Railjack action set at the top (actually there's too many action sets to see them all but I assure you it's just the Launcher and Frame Fighter one, off screen, as could be seen here:

https://imgur.com/a/xT6Cx35

So, as it currently stands when you try to pilot the Railjack, what happens is, depending on whether you're holding your melee weapon or your gun, you will get stuck in the "Game" or "Melee Mode" action sets on pilot. Some of the actions from these sets already work, so there's probably not quite as much to add here as meets the eye, so much as copy some actions to a new Railjack set. I feel the existing Mouse on right touch pad is already fine as usual, movement seems fine as well, I think the ability menu for using the ship battle avionics is fine.

As for things that don't work however, the "Sprint" action carried over from the regular set seems to be boosting, but doing dodges/drifting doesn't work with that one, so I'm guessing that button is just boost and no maneuver or boost+maneuver combo key like PC has? I'm not really sure here, since the actual Xbox binds only show 'Boost' in them and nothing else in game and I can't figure out how to make the drifting or dodges work like on KB/M. The interact key's already working for Dismount properly. Also, Archwing Up AND Jump, both go up so that works out nicely, likewise crouch/archwing down work similarly.

So if we go by what is visible in the Railjack input filter image above for Xbox it would seem the following items need updated or are missing actions that would need implemented:

  • Fix Boost (I dunno if it just isn't working right, or if Boost, Maneuver, and Boost/Maneuver actions should be added like PC, but I can't drift with this "Sprint" action triggering it at the moment, if anyone else has input on this reply away! Maybe adding all 3 of these types as an action available would be useful)
  • Add "Switch Primary" action and add to Left Touch Pad, Right direction on default profile (I think these are for tactical menu on the left with the ability menu button held? Not sure what Switch secondary does)
  • Add "Switch Secondary" action and add to Left Touch Pad, Left direction on default profile
  • Add "Dismount" action and add to X button on default profile (but Interact action from other sets works, just needs a copy and rename)
  • Add "Ordnance" action and to Right Touch Pad Click on default profile
  • Add "Toggle Railjack Camera" action and add to Left Touch Pad, Up direction
  • Add "Move Up" action and add to A button in default profile (Remember, Archwing Up and Jump actions in other action sets seem to work for this already)
  • Add "Move Down" action and add to LB button in default profile (Remember, Archwing Down and Crouch, and combo crouch actions in other action sets seem to work for this already)
  • In the Xbox profile, LB is "Move Down / Dodge / Blink" if the Blink action is what causes the Railjack to do maneuver boosts and drifting, the Blink action needs to be on LB somehow
  • Add "Boost" action to Left Stick Click Down and add to default profile (Remember, Sprint in other action sets did boost without maneuvers already in the ground action set)
  • Add Mouse look to Right Touch Pad on touch in the default profile
  • Add "Show Pause Menu" action to Railjack action set, as the Escape menu won't function at all in Steam's style if it's blank unlike your in game one for Xbox in the screenshot, and add it to the > arrow button in the default profile
  • Add "Move" action and add it to the Left Stick in the default profile (Movement from the regular ground sets already worked this can probably be copied)

Now the #2 Problem!

The tl'dr of Problem #2: Archwing Blink has no action to do it, and the Archwing Move Down action doesn't do it. The function needs added to the "Archwing Move Down" action or added separately as an "Archwing Blink" action in the Steam Input API, and then added as an additional default bind to the default gamepad profile in Steam from DE. Latter option is much more flexible and recommended imho.

My commentary on Problem #2:
Archwing Blink still doesn't work. While I know resetting binds to default for Xbox worked for the Xbox pads, that has had no bearing on the Steam Controller for myself. I could generically set the Steam bind to a keyboard bind bound to 'roll' in game which would do this, or, Xbox LB. The problem with Xbox LB however, is that item in game already has other stuff on it, for everything, dodging, archwing move down, etc. It's going to be a janky mess to work that into a Steam Controller profile as the SC is just not like the average Xbox style, many players will move many of these actions around to suit, because of how it's built and generically binding LB will make a mess of things as it's not really made to work quite that way, especially with the existing actions we're used to. This controller is great, but it's oddball since it has inner grips, a large right touch pad that can have many binds on it depending on how it's configured, including the aiming itself, but a small face button layout which makes it kinda bizarre, compared to a PS4/Xbox pad anyway, but it's really awesome when you get used to it, especially since it has vastly superior aiming ability.

But anyway, for example, if I were to do any Archwing and had a key bound to keyboard roll, and bound it, I could blink, but, when I'm on ground again hitting that button will end up rolling every time, plus whatever else is bound on it in Steam's configurator. Likewise, if I were to bind Xinput LB to it, I'd end up doing everything bound to LB by the game itself (which is multiple actions already,) as well as anything on the bind in Steam's configurator (which again would multiple actions already by default) This would be very messy flipping between these two pad editors trying to jerry rig the in game one to make up for actions the game has missing from Steam's Input API. Gamepads have limited space, so as you know often more than one action is bound to the same button, so that 'roll' is going to end up conflicting with any other thing you stuck on that button if you're using anything other than the default, of course.

Since Archwing doesn't have it's own action set, this can't be cleanly correctly without an "Archwing Blink" action being added, or, modifying the "Archwing Move Down" Steam Input action, to have blink, which is somewhat similar to the "Move Down / Dodge / Blink" action, used in the in game binds for Xinput controllers, sans the Dodge of course. I would recommend though, just making the new action "Blink" solo and let people just choose to bind more than one action to the same button I feel this will lead to the cleanest layouts people can make! Also of course, you'd need to add this as one of the default actions to LB in the default profile from DE to load as well in both the "Game" and "Melee Mode" action sets.

Oh also, if it helps you in any case, it seems your logs already know this set is missing as this happens frequently when attempting to fly the ship:
4446.412 Input [Info]: GamepadDeviceSteam::InitMapping() called with unknown InputFilter 'RailjackInputFilter' (may need adding to SteamActionSets in InputController)

Phew, hope that's everything for now. Anyway thanks for taking a look, wow writing this up took entirely more time than I expected lol. Anyway I hoped to possibly streamline what's missing and needed on the Steam Input actions. Even if you had to run a quick half assed version for a while, if you could at least add a Railjack action set to load when piloting so we could bind buttons to keyboard or regular Xbox pad inputs it would be a start to getting things working in RJ! But, I know you guys are busy, lot of RJ to fix and liches hadn't had a lot of run time before this hit either, so good luck on the hotfixes guys.

Edited by Drex83
  • Like 3
Link to comment
Share on other sites

  • 2 years later...

I just found out that this is a problem (my ps4 controller broke, so i had to use the only other controller that i had at hand, a steam controller), i experienced it first hand. Althought the major issue that i have is that i can't turn the ship at a decent speed, and what i mean by this is that i have to swipe my finger repeateadly to turn the ship a couple degrees... and this is not optimal at all.

 

I'm bumping this thread, because this is still a problem and there's no way that i'm making a more detailed one that this guy.

Link to comment
Share on other sites

i have a Red Dragon gaming mouse with 12 buttons on the thumb side and today when i went into a rail jack mission they don't work while piloting the railjack but work fine wile plating the warframe portion of the game . Please fix this it makes playing rail jack ten times harder since i have been used to playing this way in your game for YEARS

Link to comment
Share on other sites

  • 2 months later...

Somehow until recently blink worked for me on PS4 controller + Steam Input, but then I installed warframe on my laptop and it didn't work there, I started messing with the configuration and it stopped working on my PC, too. I can't get it back, even though I've reverted all the changes.

Also I've recently started playing railjack and it's glitchy as hell, sometimes forward artillery works when I hold trigger, sometimes it doesnt and makes me use touchpad to fire. There are other glitches, too, but not input related so won't post about them here.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...