Jump to content
Jade Shadows: Share Bug Reports and Feedback Here! ×
Jade Shadows: Known Issues ×

Artemis Bow Glitch


xappan
 Share

Recommended Posts

Basically I don't know what lead to it, but I was playing with Ivara Prime using her Artemis Bow Prime, and when I tried to stop using it by pressing 4 it played the animation of putting it away, the ability deactivated, but the weapon didn't go away. I still fired with it, it took my energy, although I still could fire when I had 0 energy only shooting 2 arrows each time. The weapon completely overwritten my primary weapon which I was unable to access from that point on. I could still switch to my secondary + melee (pandero + halikar) and melee only but switching to primary just brought out the bow (without activating the power itself). Could be because I tried to guide an arrow with my Navigator power but I don't know. After a while in an attempt to put the bow away I pressed 4 at which point it got completely stuck, I couldn't fire the weapon, I couldn't switch weapons, I couldn't use any of my powers, etc. I could still move but no form of attacking whatsoever. Going back to the orbiter I have my primary once again.

  • Like 1
Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...